Format lists in src/common/Makefile.am
[lttng-tools.git] / src / common / Makefile.am
index dc69f179a9e8c7da0182b8768450a6e2eafd874b..437bcd812f864972070e3d4b03df41fa672c7678 100644 (file)
@@ -4,43 +4,75 @@ SUBDIRS = string-utils
 
 # Make sure to always distribute all folders
 # since SUBDIRS is decided at configure time.
-DIST_SUBDIRS = compat health hashtable kernel-ctl sessiond-comm relayd \
-         kernel-consumer ust-consumer testpoint index config consumer \
-         string-utils fd-tracker
-#
+DIST_SUBDIRS = \
+       compat \
+       health \
+       hashtable \
+       kernel-ctl \
+       sessiond-comm \
+       relayd \
+       kernel-consumer \
+       ust-consumer \
+       testpoint \
+       index \
+       config \
+       consumer \
+       string-utils \
+       fd-tracker
+
 # Common library
 noinst_LTLIBRARIES = libcommon.la
 EXTRA_DIST = mi-lttng-3.0.xsd
 
-libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.h runas.c \
-                       common.h futex.c futex.h uri.c uri.h defaults.c \
-                       pipe.c pipe.h readwrite.c readwrite.h \
-                       mi-lttng.h mi-lttng.c \
-                       daemonize.c daemonize.h \
-                       unix.c unix.h \
-                       filter.c filter.h context.c context.h \
-                       action.c notify.c condition.c buffer-usage.c \
-                       session-consumed-size.c \
-                       session-rotation.c \
-                       evaluation.c notification.c trigger.c endpoint.c \
-                       dynamic-buffer.h dynamic-buffer.c \
-                       buffer-view.h buffer-view.c \
-                       location.c \
-                       waiter.h waiter.c \
-                       userspace-probe.c event.c time.c \
-                       session-descriptor.c credentials.h \
-                       trace-chunk.c trace-chunk.h trace-chunk-registry.h \
-                       dynamic-array.h dynamic-array.c optional.h \
-                       uuid.c uuid.h
+libcommon_la_SOURCES = \
+       action.c \
+       buffer-usage.c \
+       buffer-view.h buffer-view.c \
+       common.h \
+       condition.c \
+       context.c context.h \
+       credentials.h \
+       daemonize.c daemonize.h \
+       defaults.c \
+       dynamic-array.c dynamic-array.h \
+       dynamic-buffer.c dynamic-buffer.h \
+       endpoint.c \
+       error.c error.h \
+       evaluation.c \
+       event.c \
+       filter.c filter.h \
+       futex.c futex.h \
+       location.c \
+       mi-lttng.c mi-lttng.h \
+       notification.c \
+       notify.c \
+       optional.h \
+       pipe.c pipe.h \
+       readwrite.c readwrite.h \
+       runas.c runas.h \
+       session-consumed-size.c \
+       session-descriptor.c \
+       session-rotation.c \
+       time.c \
+       trace-chunk.c trace-chunk.h \
+       trace-chunk-registry.h \
+       trigger.c \
+       unix.c unix.h \
+       uri.c uri.h \
+       userspace-probe.c \
+       utils.c utils.h \
+       uuid.c uuid.h \
+       waiter.c waiter.h
 
 if HAVE_ELF_H
-libcommon_la_SOURCES += lttng-elf.h lttng-elf.c
+libcommon_la_SOURCES += \
+       lttng-elf.c lttng-elf.h
 endif
 
 libcommon_la_LIBADD = \
-               $(top_builddir)/src/common/config/libconfig.la \
-               $(top_builddir)/src/common/compat/libcompat.la \
-               $(top_builddir)/src/common/hashtable/libhashtable.la
+       $(top_builddir)/src/common/config/libconfig.la \
+       $(top_builddir)/src/common/compat/libcompat.la \
+       $(top_builddir)/src/common/hashtable/libhashtable.la
 
 if BUILD_LIB_COMPAT
 SUBDIRS += compat
@@ -90,9 +122,18 @@ if BUILD_LIB_CONSUMER
 SUBDIRS += consumer
 endif
 
-noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h futex.h \
-                                uri.h utils.h lttng-kernel-old.h \
-                                align.h bug.h time.h
+noinst_HEADERS = \
+       align.h \
+       bug.h \
+       defaults.h \
+       error.h \
+       futex.h \
+       lttng-kernel.h \
+       lttng-kernel-old.h \
+       macros.h \
+       time.h \
+       uri.h \
+       utils.h
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.024691 seconds and 4 git commands to generate.