Revert FreeBSD compatibility layer
[lttng-tools.git] / src / common / Makefile.am
index ba93810a8c3fe6af5bf8bd7c4188d037de4421ec..37f9acb9ab144b9a7ce711b4062d62a82bc78a4a 100644 (file)
@@ -10,17 +10,6 @@ noinst_LTLIBRARIES = libcommon.la
 
 libcommon_la_SOURCES = runas.c runas.h common.h
 
-if COMPAT_EPOLL
-COMPAT=compat/compat-epoll.c
-else
-COMPAT=compat/compat-poll.c
-endif
-
-noinst_LTLIBRARIES += libcompat.la
-
-libcompat_la_SOURCES = compat/poll.h compat/fcntl.h compat/splice.h compat/endian.h \
-                       compat/socket.h compat/compat-fcntl.c $(COMPAT)
-
 # Consumer library
 noinst_LTLIBRARIES += libconsumer.la
 
@@ -29,10 +18,19 @@ libconsumer_la_SOURCES = consumer.c consumer.h
 libconsumer_la_LIBADD = \
                $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
                $(top_builddir)/src/common/kernel-consumer/libkernel-consumer.la \
-               $(top_builddir)/src/common/hashtable/libhashtable.la \
-               $(top_builddir)/src/common/libcompat.la
+               $(top_builddir)/src/common/hashtable/libhashtable.la
 
 if HAVE_LIBLTTNG_UST_CTL
 libconsumer_la_LIBADD += \
                $(top_builddir)/src/common/ust-consumer/libust-consumer.la
 endif
+
+if COMPAT_EPOLL
+COMPAT=compat/compat-epoll.c
+else
+COMPAT=compat/compat-poll.c
+endif
+
+noinst_LTLIBRARIES += libcompat.la
+
+libcompat_la_SOURCES = compat/poll.h $(COMPAT)
This page took 0.024121 seconds and 4 git commands to generate.