Move utils_expand_path and utils_expand_path_keep_symlink to libpath.la
[lttng-tools.git] / src / common / Makefile.am
index 7c2ab3e3a193dfa663827a54a8ba8f598cd8fc82..1ac4874a02a5f50589a11e7a309167aef0dec50e 100644 (file)
@@ -2,7 +2,17 @@
 
 AUTOMAKE_OPTIONS = subdir-objects
 
-SUBDIRS = string-utils filter
+SUBDIRS = \
+       argpar \
+       bytecode \
+       compat \
+       config \
+       ini-config \
+       fd-tracker \
+       string-utils \
+       filter \
+       hashtable \
+       argpar-utils
 
 # Make sure to always distribute all folders
 # since SUBDIRS is decided at configure time.
@@ -18,96 +28,131 @@ DIST_SUBDIRS = \
        testpoint \
        index \
        config \
+       ini-config \
        consumer \
        string-utils \
        fd-tracker \
-       filter
+       bytecode \
+       filter \
+       argpar \
+       argpar-utils
+
 # Common library
-noinst_LTLIBRARIES = libcommon.la
-EXTRA_DIST = mi-lttng-4.0.xsd
-
-libcommon_la_SOURCES = \
-       actions/action.c \
-       actions/group.c \
-       actions/notify.c \
-       actions/rotate-session.c \
-       actions/snapshot-session.c \
-       actions/start-session.c \
-       actions/stop-session.c \
-       buffer-usage.c \
-       buffer-view.h buffer-view.c \
-       common.h \
-       condition.c \
-       context.c context.h \
-       credentials.c credentials.h \
-       daemonize.c daemonize.h \
-       defaults.c \
-       dynamic-array.c dynamic-array.h \
-       dynamic-buffer.c dynamic-buffer.h \
-       endpoint.c \
-       error.c error.h \
-       evaluation.c \
-       event.c \
-       event-rule/event-rule.c \
-       event-rule/kprobe.c \
-       event-rule/syscall.c \
-       event-rule/uprobe.c \
-       filter.c filter.h \
-       fd-handle.c fd-handle.h \
-       fs-handle.c fs-handle.h fs-handle-internal.h \
-       futex.c futex.h \
-       kernel-probe.c \
-       location.c \
-       mi-lttng.c mi-lttng.h \
-       notification.c \
-       optional.h \
-       payload.c payload.h \
-       payload-view.c payload-view.h \
-       pipe.c pipe.h \
-       readwrite.c readwrite.h \
-       runas.c runas.h \
-       session-consumed-size.c \
-       session-descriptor.c \
-       session-rotation.c \
-       snapshot.c snapshot.h \
-       spawn-viewer.c spawn-viewer.h \
-       time.c \
-       trace-chunk.c trace-chunk.h \
-       trace-chunk-registry.h \
-       trigger.c \
-       unix.c unix.h \
-       uri.c uri.h \
-       userspace-probe.c \
-       utils.c utils.h \
-       uuid.c uuid.h \
-       thread.c thread.h \
-       tracker.c tracker.h \
-       waiter.c waiter.h
+noinst_LTLIBRARIES = libpath.la libcommon-lgpl.la libcommon-gpl.la
+EXTRA_DIST = mi-lttng-4.1.xsd
+
+# The libcommon-lgpl static archive contains only LGPLv2.1 code. It is
+# meant to be used by LGPLv2.1 libraries such as liblttng-ctl. It also
+# contains libcommon-lgpl.la.
+
+libcommon_lgpl_la_SOURCES = \
+       actions/action.cpp \
+       actions/list.cpp \
+       actions/notify.cpp \
+       actions/path.cpp \
+       actions/rotate-session.cpp \
+       actions/snapshot-session.cpp \
+       actions/start-session.cpp \
+       actions/stop-session.cpp \
+       actions/rate-policy.cpp \
+       buffer-view.h buffer-view.cpp \
+       conditions/buffer-usage.cpp \
+       conditions/condition.cpp \
+       conditions/event-rule-matches.cpp \
+       conditions/session-consumed-size.cpp \
+       conditions/session-rotation.cpp \
+       credentials.cpp credentials.h \
+       defaults.cpp \
+       domain.cpp \
+       dynamic-array.cpp dynamic-array.h \
+       dynamic-buffer.cpp dynamic-buffer.h \
+       endpoint.cpp \
+       error.cpp error.h \
+       error-query.cpp \
+       evaluation.cpp \
+       event-expr/event-expr.cpp \
+       event-field-value.cpp \
+       event-rule/event-rule.cpp \
+       event-rule/kernel-kprobe.cpp \
+       event-rule/kernel-syscall.cpp \
+       event-rule/kernel-uprobe.cpp \
+       event-rule/kernel-tracepoint.cpp \
+       event-rule/user-tracepoint.cpp \
+       event-rule/log4j-logging.cpp \
+       event-rule/jul-logging.cpp \
+       event-rule/python-logging.cpp \
+       fd-handle.cpp fd-handle.h \
+       kernel-probe.cpp \
+       location.cpp \
+       log-level-rule.cpp \
+       mi-lttng.cpp mi-lttng.h \
+       notification.cpp \
+       payload.cpp payload.h \
+       payload-view.cpp payload-view.h \
+       readwrite.cpp readwrite.h \
+       runas.cpp runas.h \
+       session-descriptor.cpp \
+       snapshot.cpp snapshot.h \
+       spawn-viewer.cpp spawn-viewer.h \
+       thread.cpp thread.h \
+       time.cpp \
+       tracker.cpp tracker.h \
+       trigger.cpp \
+       unix.cpp unix.h \
+       uri.cpp uri.h \
+       userspace-probe.cpp \
+       utils.cpp utils.h
 
 if HAVE_ELF_H
-libcommon_la_SOURCES += \
-       lttng-elf.c lttng-elf.h
+libcommon_lgpl_la_SOURCES += \
+       lttng-elf.cpp lttng-elf.h
 endif
 
-libcommon_la_LIBADD = \
-       $(top_builddir)/src/common/config/libconfig.la \
+libcommon_lgpl_la_LIBADD = \
+       $(top_builddir)/src/common/bytecode/libbytecode.la \
        $(top_builddir)/src/common/compat/libcompat.la \
-       $(top_builddir)/src/common/hashtable/libhashtable.la \
-       $(top_builddir)/src/common/fd-tracker/libfd-tracker.la \
-       $(top_builddir)/src/common/filter/libfilter.la
+       $(top_builddir)/src/common/config/libconfig.la \
+       $(top_builddir)/src/common/filter/libfilter.la \
+       $(top_builddir)/src/common/hashtable/libhashtable-lgpl.la \
+       $(top_builddir)/src/vendor/msgpack/libmsgpack.la
 
-if BUILD_LIB_COMPAT
-SUBDIRS += compat
-endif
+# The libpath static archive contains GPLv2 compatible code. It is
+# meant to be used by GPL executables.
+
+libpath_la_SOURCES = \
+       path.cpp path.h
+
+# The libcommon-gpl static archive contains GPLv2 compatible code. It is
+# meant to be used by GPL executables.
+
+libcommon_gpl_la_SOURCES = \
+       common.h \
+       context.cpp context.h \
+       daemonize.cpp daemonize.h \
+       event.cpp \
+       filter.cpp filter.h \
+       fs-handle.cpp fs-handle.h fs-handle-internal.h \
+       futex.cpp futex.h \
+       index-allocator.cpp index-allocator.h \
+       optional.h \
+       pipe.cpp pipe.h \
+       shm.cpp shm.h \
+       trace-chunk.cpp trace-chunk.h \
+       trace-chunk-registry.h \
+       uuid.cpp uuid.h \
+       waiter.cpp waiter.h
+
+libcommon_gpl_la_LIBADD = \
+       libcommon-lgpl.la \
+       libpath.la \
+       $(top_builddir)/src/common/ini-config/libini-config.la \
+       $(top_builddir)/src/common/hashtable/libhashtable-gpl.la \
+       $(top_builddir)/src/common/fd-tracker/libfd-tracker.la
 
 if BUILD_LIB_HEALTH
 SUBDIRS += health
 endif
 
-if BUILD_LIB_HASHTABLE
-SUBDIRS += hashtable
-endif
-
 if BUILD_LIB_KERNEL_CTL
 SUBDIRS += kernel-ctl
 endif
@@ -120,9 +165,6 @@ if BUILD_LIB_RELAYD
 SUBDIRS += relayd
 endif
 
-if BUILD_LIB_FD_TRACKER
-SUBDIRS += fd-tracker
-endif
 
 if BUILD_LIB_KERNEL_CONSUMER
 SUBDIRS += kernel-consumer
@@ -140,10 +182,6 @@ if BUILD_LIB_INDEX
 SUBDIRS += index
 endif
 
-if BUILD_LIB_CONFIG
-SUBDIRS += config
-endif
-
 if BUILD_LIB_CONSUMER
 SUBDIRS += consumer
 endif
@@ -161,6 +199,10 @@ noinst_HEADERS = \
        uri.h \
        utils.h
 
+noinst_PROGRAMS = filter-grammar-test
+filter_grammar_test_SOURCES = filter-grammar-test.cpp
+filter_grammar_test_LDADD = libcommon-gpl.la
+
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
                for script in $(EXTRA_DIST); do \
This page took 0.030772 seconds and 4 git commands to generate.