lttng: Add list-triggers command
[lttng-tools.git] / src / bin / lttng / Makefile.am
index acd973b255b3898ac2d15025cf6d03eef446f4f0..7a305d49ae8cd07950e94455a508bf6a6e9dcadc 100644 (file)
@@ -1,5 +1,10 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src \
-                         -DINSTALL_BIN_PATH=\""$(bindir)"\"
+# SPDX-License-Identifier: GPL-2.0-only
+
+AM_CPPFLAGS += -DINSTALL_BIN_PATH=\""$(bindir)"\"
+
+if EMBED_HELP
+AM_CPPFLAGS += -I$(top_builddir)/doc/man
+endif
 
 AUTOMAKE_OPTIONS = subdir-objects
 
@@ -11,7 +16,7 @@ lttng_SOURCES = command.h conf.c conf.h commands/start.c \
                                commands/disable_events.c commands/enable_channels.c \
                                commands/disable_channels.c commands/add_context.c \
                                commands/set_session.c commands/version.c \
-                               commands/calibrate.c commands/view.c \
+                               commands/view.c \
                                commands/snapshot.c \
                                commands/save.c \
                                commands/load.c \
@@ -20,8 +25,22 @@ lttng_SOURCES = command.h conf.c conf.h commands/start.c \
                                commands/metadata.c \
                                commands/regenerate.c \
                                commands/help.c \
-                               utils.c utils.h lttng.c
+                               commands/rotate.c \
+                               commands/enable_rotation.c \
+                               commands/disable_rotation.c \
+                               commands/clear.c \
+                               loglevel.c loglevel.h \
+                               commands/add_trigger.c \
+                               commands/list_triggers.c \
+                               utils.c utils.h lttng.c \
+                               uprobe.c uprobe.h
+
+lttng_CFLAGS = $(AM_CFLAGS) $(POPT_CFLAGS)
 
 lttng_LDADD = $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
                        $(top_builddir)/src/common/libcommon.la \
-                       $(top_builddir)/src/common/config/libconfig.la
+                       $(top_builddir)/src/common/config/libconfig.la \
+                       $(top_builddir)/src/common/string-utils/libstring-utils.la \
+                       $(top_builddir)/src/common/filter/libfilter.la \
+                       $(top_builddir)/src/common/argpar/libargpar.la \
+                       $(POPT_LIBS)
This page took 0.023344 seconds and 4 git commands to generate.