lttng: Add list-triggers command
[lttng-tools.git] / src / bin / lttng / Makefile.am
index 62ae059374063e0aa010b9bb921da7d8ace07fb7..7a305d49ae8cd07950e94455a508bf6a6e9dcadc 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 AM_CPPFLAGS += -DINSTALL_BIN_PATH=\""$(bindir)"\"
 
 if EMBED_HELP
@@ -26,7 +28,12 @@ lttng_SOURCES = command.h conf.c conf.h commands/start.c \
                                commands/rotate.c \
                                commands/enable_rotation.c \
                                commands/disable_rotation.c \
-                               utils.c utils.h lttng.c
+                               commands/clear.c \
+                               loglevel.c loglevel.h \
+                               commands/add_trigger.c \
+                               commands/list_triggers.c \
+                               utils.c utils.h lttng.c \
+                               uprobe.c uprobe.h
 
 lttng_CFLAGS = $(AM_CFLAGS) $(POPT_CFLAGS)
 
@@ -34,4 +41,6 @@ lttng_LDADD = $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
                        $(top_builddir)/src/common/libcommon.la \
                        $(top_builddir)/src/common/config/libconfig.la \
                        $(top_builddir)/src/common/string-utils/libstring-utils.la \
+                       $(top_builddir)/src/common/filter/libfilter.la \
+                       $(top_builddir)/src/common/argpar/libargpar.la \
                        $(POPT_LIBS)
This page took 0.023187 seconds and 4 git commands to generate.