lttng: Add remove-trigger command
[lttng-tools.git] / src / bin / lttng / Makefile.am
index b56ba2be83d5a2551667390f8db9c2fbb82d132c..50ab92988db3d88b957bc3aba9af6181d12d73ec 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 AM_CPPFLAGS += -DINSTALL_BIN_PATH=\""$(bindir)"\"
 
 if EMBED_HELP
@@ -24,10 +26,22 @@ lttng_SOURCES = command.h conf.c conf.h commands/start.c \
                                commands/regenerate.c \
                                commands/help.c \
                                commands/rotate.c \
-                               utils.c utils.h lttng.c
+                               commands/enable_rotation.c \
+                               commands/disable_rotation.c \
+                               commands/clear.c \
+                               loglevel.c loglevel.h \
+                               commands/add_trigger.c \
+                               commands/list_triggers.c \
+                               commands/remove_trigger.c \
+                               utils.c utils.h lttng.c \
+                               uprobe.c uprobe.h
+
+lttng_CFLAGS = $(AM_CFLAGS) $(POPT_CFLAGS)
 
 lttng_LDADD = $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
                        $(top_builddir)/src/common/libcommon.la \
                        $(top_builddir)/src/common/config/libconfig.la \
                        $(top_builddir)/src/common/string-utils/libstring-utils.la \
+                       $(top_builddir)/src/common/filter/libfilter.la \
+                       $(top_builddir)/src/common/argpar/libargpar.la \
                        $(POPT_LIBS)
This page took 0.02341 seconds and 4 git commands to generate.