lttng: Add remove-trigger command
[lttng-tools.git] / src / bin / lttng / Makefile.am
index 03aa31bd04e153e41afaba8d127c80cd123c60bb..50ab92988db3d88b957bc3aba9af6181d12d73ec 100644 (file)
@@ -1,5 +1,10 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src \
-                         -DINSTALL_BIN_PATH=\""$(bindir)"\"
+# SPDX-License-Identifier: GPL-2.0-only
+
+AM_CPPFLAGS += -DINSTALL_BIN_PATH=\""$(bindir)"\"
+
+if EMBED_HELP
+AM_CPPFLAGS += -I$(top_builddir)/doc/man
+endif
 
 AUTOMAKE_OPTIONS = subdir-objects
 
@@ -20,8 +25,23 @@ lttng_SOURCES = command.h conf.c conf.h commands/start.c \
                                commands/metadata.c \
                                commands/regenerate.c \
                                commands/help.c \
-                               utils.c utils.h lttng.c
+                               commands/rotate.c \
+                               commands/enable_rotation.c \
+                               commands/disable_rotation.c \
+                               commands/clear.c \
+                               loglevel.c loglevel.h \
+                               commands/add_trigger.c \
+                               commands/list_triggers.c \
+                               commands/remove_trigger.c \
+                               utils.c utils.h lttng.c \
+                               uprobe.c uprobe.h
+
+lttng_CFLAGS = $(AM_CFLAGS) $(POPT_CFLAGS)
 
 lttng_LDADD = $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
                        $(top_builddir)/src/common/libcommon.la \
-                       $(top_builddir)/src/common/config/libconfig.la
+                       $(top_builddir)/src/common/config/libconfig.la \
+                       $(top_builddir)/src/common/string-utils/libstring-utils.la \
+                       $(top_builddir)/src/common/filter/libfilter.la \
+                       $(top_builddir)/src/common/argpar/libargpar.la \
+                       $(POPT_LIBS)
This page took 0.023121 seconds and 4 git commands to generate.