Fix: sessiond: check for lttng-modules ABI 2.1 rather than 2.8
[lttng-tools.git] / src / bin / lttng-sessiond / kernel.c
index 1f987ef7d365a2890146d5c5cccdc1f3cf72660a..2626e98b259f46eeebbeee69be8bc1935cb43dfa 100644 (file)
@@ -1445,9 +1445,10 @@ int kernel_supports_ring_buffer_packet_sequence_number(void)
        }
 
        /*
-        * Packet sequence number was introduced in 2.8
+        * Packet sequence number was introduced in LTTng 2.8,
+        * lttng-modules ABI 2.1.
         */
-       if (abi.major >= 2 && abi.minor >= 8) {
+       if (abi.major >= 2 && abi.minor >= 1) {
                /* Supported */
                ret = 1;
        } else {
This page took 0.031388 seconds and 4 git commands to generate.