Launch the ust registration dispatch thread using lttng_thread
[lttng-tools.git] / src / bin / lttng-sessiond / Makefile.am
index 529887b8a75ae12a6e2f4542550cca5d3aa680f2..ec0a74c4e89272fb0a02a9a92d08f814a3c14b2f 100644 (file)
@@ -31,22 +31,36 @@ lttng_sessiond_SOURCES = utils.c utils.h \
                        agent.c agent.h \
                        save.h save.c \
                        load-session-thread.h load-session-thread.c \
-                       syscall.h syscall.c \
+                       lttng-syscall.h lttng-syscall.c \
                        notification-thread.h notification-thread.c \
+                       notification-thread-internal.h \
                        notification-thread-commands.h notification-thread-commands.c \
-                       notification-thread-events.h notification-thread-events.c
+                       notification-thread-events.h notification-thread-events.c \
+                       sessiond-config.h sessiond-config.c \
+                       rotate.h rotate.c \
+                       rotation-thread.h rotation-thread.c \
+                       timer.c timer.h \
+                       ready.c \
+                       globals.c \
+                       thread-utils.c \
+                       process-utils.c \
+                       thread.c thread.h \
+                       health.c \
+                       client.c client.h \
+                       dispatch.c dispatch.h
 
 if HAVE_LIBLTTNG_UST_CTL
 lttng_sessiond_SOURCES += trace-ust.c ust-registry.c ust-app.c \
                        ust-consumer.c ust-consumer.h ust-thread.c \
-                       ust-metadata.c ust-clock.h agent-thread.c agent-thread.h
+                       ust-metadata.c ust-clock.h agent-thread.c agent-thread.h \
+                       ust-field-utils.h ust-field-utils.c
 endif
 
 # Add main.c at the end for compile order
 lttng_sessiond_SOURCES += lttng-sessiond.h main.c
 
 # link on liblttngctl for check if sessiond is already alive.
-lttng_sessiond_LDADD = -lurcu-common -lurcu \
+lttng_sessiond_LDADD = -lurcu-common -lurcu $(KMOD_LIBS) \
                $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
                $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
                $(top_builddir)/src/common/kernel-ctl/libkernel-ctl.la \
This page took 0.02372 seconds and 4 git commands to generate.