Launch the ust registration dispatch thread using lttng_thread
[lttng-tools.git] / src / bin / lttng-sessiond / Makefile.am
index 4da4e6bab15cff2ef5cb467a4ad2a50f9fa5825b..ec0a74c4e89272fb0a02a9a92d08f814a3c14b2f 100644 (file)
@@ -31,19 +31,29 @@ lttng_sessiond_SOURCES = utils.c utils.h \
                        agent.c agent.h \
                        save.h save.c \
                        load-session-thread.h load-session-thread.c \
-                       syscall.h syscall.c \
+                       lttng-syscall.h lttng-syscall.c \
                        notification-thread.h notification-thread.c \
+                       notification-thread-internal.h \
                        notification-thread-commands.h notification-thread-commands.c \
                        notification-thread-events.h notification-thread-events.c \
                        sessiond-config.h sessiond-config.c \
                        rotate.h rotate.c \
                        rotation-thread.h rotation-thread.c \
-                       sessiond-timer.c sessiond-timer.h
+                       timer.c timer.h \
+                       ready.c \
+                       globals.c \
+                       thread-utils.c \
+                       process-utils.c \
+                       thread.c thread.h \
+                       health.c \
+                       client.c client.h \
+                       dispatch.c dispatch.h
 
 if HAVE_LIBLTTNG_UST_CTL
 lttng_sessiond_SOURCES += trace-ust.c ust-registry.c ust-app.c \
                        ust-consumer.c ust-consumer.h ust-thread.c \
-                       ust-metadata.c ust-clock.h agent-thread.c agent-thread.h
+                       ust-metadata.c ust-clock.h agent-thread.c agent-thread.h \
+                       ust-field-utils.h ust-field-utils.c
 endif
 
 # Add main.c at the end for compile order
This page took 0.023415 seconds and 4 git commands to generate.