Cleanup: Move `create_posix_shm()` to common/shm.c
[lttng-tools.git] / src / bin / lttng-sessiond / Makefile.am
index 2e4b95dcef0beb5334f130fe20e9134854d02e01..e71c1081443744445bbdeed89895c75c94979593 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 AM_CPPFLAGS +=-DINSTALL_BIN_PATH=\""$(lttnglibexecdir)"\" \
        -DINSTALL_LIB_PATH=\""$(libdir)"\"
 
@@ -10,16 +12,17 @@ bin_PROGRAMS = lttng-sessiond
 lttng_sessiond_SOURCES = utils.c utils.h \
                        trace-kernel.c trace-kernel.h \
                        kernel.c kernel.h \
-                       ust-ctl.h ust-app.h trace-ust.h ust-thread.h \
+                       ust-app.h trace-ust.h notify-apps.h \
+                       lttng-ust-ctl.h lttng-ust-abi.h lttng-ust-error.h \
+                       ust-ctl-internal.h ust-abi-internal.h ust-error-internal.h \
                        ust-registry.h \
+                       condition-internal.c condition-internal.h \
                        context.c context.h \
                        channel.c channel.h \
                        event.c event.h \
-                       shm.c shm.h \
                        consumer.c consumer.h \
                        session.c session.h \
                        modprobe.c modprobe.h kern-modules.h \
-                       lttng-ust-ctl.h lttng-ust-abi.h lttng-ust-error.h \
                        fd-limit.c fd-limit.h \
                        kernel-consumer.c kernel-consumer.h \
                        consumer.h \
@@ -30,7 +33,6 @@ lttng_sessiond_SOURCES = utils.c utils.h \
                        snapshot.c snapshot.h \
                        agent.c agent.h \
                        save.h save.c \
-                       load-session-thread.h load-session-thread.c \
                        lttng-syscall.h lttng-syscall.c \
                        notification-thread.h notification-thread.c \
                        notification-thread-internal.h \
@@ -39,11 +41,25 @@ lttng_sessiond_SOURCES = utils.c utils.h \
                        sessiond-config.h sessiond-config.c \
                        rotate.h rotate.c \
                        rotation-thread.h rotation-thread.c \
-                       timer.c timer.h
+                       timer.c timer.h \
+                       globals.c \
+                       thread-utils.c \
+                       process-utils.c \
+                       thread.c thread.h \
+                       health.c \
+                       client.c client.h \
+                       dispatch.c dispatch.h \
+                       register.c register.h \
+                       manage-apps.c manage-apps.h \
+                       manage-kernel.c manage-kernel.h \
+                       manage-consumer.c manage-consumer.h \
+                       clear.c clear.h \
+                       tracker.c tracker.h \
+                       action-executor.c action-executor.h
 
 if HAVE_LIBLTTNG_UST_CTL
 lttng_sessiond_SOURCES += trace-ust.c ust-registry.c ust-app.c \
-                       ust-consumer.c ust-consumer.h ust-thread.c \
+                       ust-consumer.c ust-consumer.h notify-apps.c \
                        ust-metadata.c ust-clock.h agent-thread.c agent-thread.h \
                        ust-field-utils.h ust-field-utils.c
 endif
@@ -52,7 +68,7 @@ endif
 lttng_sessiond_SOURCES += lttng-sessiond.h main.c
 
 # link on liblttngctl for check if sessiond is already alive.
-lttng_sessiond_LDADD = -lurcu-common -lurcu $(KMOD_LIBS) \
+lttng_sessiond_LDADD = -lurcu-common $(URCU_LIBS) $(KMOD_LIBS) \
                $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
                $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
                $(top_builddir)/src/common/kernel-ctl/libkernel-ctl.la \
@@ -67,5 +83,5 @@ lttng_sessiond_LDADD = -lurcu-common -lurcu $(KMOD_LIBS) \
 
 
 if HAVE_LIBLTTNG_UST_CTL
-lttng_sessiond_LDADD += -llttng-ust-ctl
+lttng_sessiond_LDADD += $(UST_CTL_LIBS)
 endif
This page took 0.02557 seconds and 4 git commands to generate.