Add testpoints in lttng-sessiond for each threads
[lttng-tools.git] / src / bin / lttng-sessiond / Makefile.am
index 9b9713b2b068c8e89d1b636895e840bfa16385ed..b13059d77a155d03a4a13f7cf570e5499c432fbd 100644 (file)
@@ -13,12 +13,16 @@ lttng_sessiond_SOURCES = utils.c utils.h \
                        channel.c channel.h \
                        event.c event.h \
                        shm.c shm.h \
+                       consumer.c consumer.h \
                        session.c session.h \
                        modprobe.c modprobe.h kern-modules.h \
                        lttng-ust-ctl.h lttng-ust-abi.h \
                        fd-limit.c fd-limit.h \
                        kernel-consumer.c kernel-consumer.h \
-                       consumer.h
+                       consumer.h filter.c filter.h \
+                       health.c health.h \
+                       cmd.c cmd.h \
+                       testpoint.h
 
 if HAVE_LIBLTTNG_UST_CTL
 lttng_sessiond_SOURCES += trace-ust.c ust-app.c ust-consumer.c ust-consumer.h
@@ -34,7 +38,9 @@ lttng_sessiond_LDADD = -lrt -lurcu-common -lurcu \
                $(top_builddir)/src/common/kernel-ctl/libkernel-ctl.la \
                $(top_builddir)/src/common/hashtable/libhashtable.la \
                $(top_builddir)/src/common/libcommon.la \
-               $(top_builddir)/src/common/compat/libcompat.la
+               $(top_builddir)/src/common/compat/libcompat.la \
+               $(top_builddir)/src/common/relayd/librelayd.la \
+               $(top_builddir)/src/common/testpoint/libtestpoint.la
 
 if HAVE_LIBLTTNG_UST_CTL
 lttng_sessiond_LDADD += -llttng-ust-ctl
This page took 0.023271 seconds and 4 git commands to generate.