Implement filter bytecode support in lttng-session, and parse filter string
[lttng-tools.git] / src / bin / lttng-sessiond / Makefile.am
index 9b9713b2b068c8e89d1b636895e840bfa16385ed..0cbf0c11a8f60f44f624d0c50b65ae12d7db9e2b 100644 (file)
@@ -17,8 +17,9 @@ lttng_sessiond_SOURCES = utils.c utils.h \
                        modprobe.c modprobe.h kern-modules.h \
                        lttng-ust-ctl.h lttng-ust-abi.h \
                        fd-limit.c fd-limit.h \
+                       consumer.c consumer.h \
                        kernel-consumer.c kernel-consumer.h \
-                       consumer.h
+                       consumer.h filter.c filter.h
 
 if HAVE_LIBLTTNG_UST_CTL
 lttng_sessiond_SOURCES += trace-ust.c ust-app.c ust-consumer.c ust-consumer.h
@@ -34,7 +35,8 @@ lttng_sessiond_LDADD = -lrt -lurcu-common -lurcu \
                $(top_builddir)/src/common/kernel-ctl/libkernel-ctl.la \
                $(top_builddir)/src/common/hashtable/libhashtable.la \
                $(top_builddir)/src/common/libcommon.la \
-               $(top_builddir)/src/common/compat/libcompat.la
+               $(top_builddir)/src/common/compat/libcompat.la \
+               $(top_builddir)/src/common/relayd/librelayd.la
 
 if HAVE_LIBLTTNG_UST_CTL
 lttng_sessiond_LDADD += -llttng-ust-ctl
This page took 0.022896 seconds and 4 git commands to generate.