Add the sessiond notification-handling subsystem
[lttng-tools.git] / src / bin / lttng-sessiond / Makefile.am
index 7819222d9aa1fc6efbd6c0fbec20a7bf31a4b1ce..0ac7506b440dc825151c32db1bbeca862c70613c 100644 (file)
@@ -25,12 +25,15 @@ lttng_sessiond_SOURCES = utils.c utils.h \
                        health-sessiond.h \
                        cmd.c cmd.h \
                        buffer-registry.c buffer-registry.h \
-                       testpoint.h ht-cleanup.c \
+                       testpoint.h ht-cleanup.c ht-cleanup.h \
                        snapshot.c snapshot.h \
                        agent.c agent.h \
                        save.h save.c \
                        load-session-thread.h load-session-thread.c \
-                       syscall.h syscall.c
+                       syscall.h syscall.c \
+                       notification-thread.h notification-thread.c \
+                       notification-thread-commands.h notification-thread-commands.c \
+                       notification-thread-events.h notification-thread-events.c
 
 if HAVE_LIBLTTNG_UST_CTL
 lttng_sessiond_SOURCES += trace-ust.c ust-registry.c ust-app.c \
@@ -42,7 +45,7 @@ endif
 lttng_sessiond_SOURCES += lttng-sessiond.h main.c
 
 # link on liblttngctl for check if sessiond is already alive.
-lttng_sessiond_LDADD = -lrt -lurcu-common -lurcu \
+lttng_sessiond_LDADD = -lurcu-common -lurcu \
                $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
                $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
                $(top_builddir)/src/common/kernel-ctl/libkernel-ctl.la \
This page took 0.023264 seconds and 4 git commands to generate.