Add the sessiond notification-handling subsystem
[lttng-tools.git] / src / bin / lttng-sessiond / Makefile.am
index 5bd62e5580b8f3e3f8478cf12d50e08db6388eac..0ac7506b440dc825151c32db1bbeca862c70613c 100644 (file)
@@ -25,23 +25,27 @@ lttng_sessiond_SOURCES = utils.c utils.h \
                        health-sessiond.h \
                        cmd.c cmd.h \
                        buffer-registry.c buffer-registry.h \
-                       testpoint.h ht-cleanup.c \
+                       testpoint.h ht-cleanup.c ht-cleanup.h \
                        snapshot.c snapshot.h \
-                       jul.c jul.h \
+                       agent.c agent.h \
                        save.h save.c \
-                       load-session-thread.h load-session-thread.c
+                       load-session-thread.h load-session-thread.c \
+                       syscall.h syscall.c \
+                       notification-thread.h notification-thread.c \
+                       notification-thread-commands.h notification-thread-commands.c \
+                       notification-thread-events.h notification-thread-events.c
 
 if HAVE_LIBLTTNG_UST_CTL
 lttng_sessiond_SOURCES += trace-ust.c ust-registry.c ust-app.c \
                        ust-consumer.c ust-consumer.h ust-thread.c \
-                       ust-metadata.c ust-clock.h jul-thread.c jul-thread.h
+                       ust-metadata.c ust-clock.h agent-thread.c agent-thread.h
 endif
 
 # Add main.c at the end for compile order
 lttng_sessiond_SOURCES += lttng-sessiond.h main.c
 
 # link on liblttngctl for check if sessiond is already alive.
-lttng_sessiond_LDADD = -lrt -lurcu-common -lurcu \
+lttng_sessiond_LDADD = -lurcu-common -lurcu \
                $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
                $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
                $(top_builddir)/src/common/kernel-ctl/libkernel-ctl.la \
This page took 0.025789 seconds and 4 git commands to generate.