Port: Link with no-undefined on Windows
[lttng-tools.git] / src / bin / lttng-relayd / Makefile.am
index 65e3d675c012b352dca06ea1f04c596cb6879f47..df87bc3005311d6b297d3680d1d7fe06306d914c 100644 (file)
@@ -15,11 +15,15 @@ lttng_relayd_SOURCES = main.c lttng-relayd.h utils.h utils.c cmd.h \
                        health-relayd.c health-relayd.h \
                        lttng-viewer-abi.h testpoint.h \
                        viewer-stream.h viewer-stream.c \
-                       session.c session.h
+                       session.c session.h \
+                       stream.c stream.h \
+                       stream-fd.c stream-fd.h \
+                       connection.c connection.h \
+                       viewer-session.c viewer-session.h \
+                       tracefile-array.c tracefile-array.h
 
 # link on liblttngctl for check if relayd is already alive.
-lttng_relayd_LDADD = -lrt -lurcu-common -lurcu \
-               $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
+lttng_relayd_LDADD = -lurcu-common -lurcu \
                $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
                $(top_builddir)/src/common/hashtable/libhashtable.la \
                $(top_builddir)/src/common/libcommon.la \
@@ -27,4 +31,5 @@ lttng_relayd_LDADD = -lrt -lurcu-common -lurcu \
                $(top_builddir)/src/common/index/libindex.la \
                $(top_builddir)/src/common/health/libhealth.la \
                $(top_builddir)/src/common/config/libconfig.la \
-               $(top_builddir)/src/common/testpoint/libtestpoint.la
+               $(top_builddir)/src/common/testpoint/libtestpoint.la \
+               $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
This page took 0.022999 seconds and 4 git commands to generate.