Revert "Fix: sessiond: erroneous user check logic in session_access_ok"
[lttng-tools.git] / src / bin / Makefile.am
index ebf9b57ff938511d12091560a16c16ffa79c6a1c..8c5803494ad3697b959c075c6dcd5835619a125e 100644 (file)
@@ -1,7 +1,30 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 ACLOCAL_AMFLAGS = -I config
 
-SUBDIRS = lttng-consumerd \
-                 lttng \
-          lttng-sessiond \
-          lttng-relayd \
-          lttng-crash
+SUBDIRS =
+
+# Make sure to always distribute all folders
+# since SUBDIRS is decided at configure time.
+DIST_SUBDIRS = lttng-consumerd lttng lttng-sessiond lttng-relayd \
+              lttng-crash
+
+if BUILD_BIN_LTTNG
+SUBDIRS += lttng
+endif
+
+if BUILD_BIN_LTTNG_CONSUMERD
+SUBDIRS += lttng-consumerd
+endif
+
+if BUILD_BIN_LTTNG_CRASH
+SUBDIRS += lttng-crash
+endif
+
+if BUILD_BIN_LTTNG_RELAYD
+SUBDIRS += lttng-relayd
+endif
+
+if BUILD_BIN_LTTNG_SESSIOND
+SUBDIRS += lttng-sessiond
+endif
This page took 0.024125 seconds and 4 git commands to generate.