Extend the rotation API to provide network trace archive locations
[lttng-tools.git] / src / bin / Makefile.am
index ebf9b57ff938511d12091560a16c16ffa79c6a1c..73cfac7b76986076f031299fc630f498ac375c9d 100644 (file)
@@ -1,7 +1,28 @@
 ACLOCAL_AMFLAGS = -I config
 
-SUBDIRS = lttng-consumerd \
-                 lttng \
-          lttng-sessiond \
-          lttng-relayd \
-          lttng-crash
+SUBDIRS =
+
+# Make sure to always distribute all folders
+# since SUBDIRS is decided at configure time.
+DIST_SUBDIRS = lttng-consumerd lttng lttng-sessiond lttng-relayd \
+              lttng-crash
+
+if BUILD_BIN_LTTNG
+SUBDIRS += lttng
+endif
+
+if BUILD_BIN_LTTNG_CONSUMERD
+SUBDIRS += lttng-consumerd
+endif
+
+if BUILD_BIN_LTTNG_CRASH
+SUBDIRS += lttng-crash
+endif
+
+if BUILD_BIN_LTTNG_RELAYD
+SUBDIRS += lttng-relayd
+endif
+
+if BUILD_BIN_LTTNG_SESSIOND
+SUBDIRS += lttng-sessiond
+endif
This page took 0.023086 seconds and 4 git commands to generate.