Add lttng_waiter utils
[lttng-tools.git] / src / bin / Makefile.am
index ce5057dd7512c007dccb6ca9fa36287f10d9b002..73cfac7b76986076f031299fc630f498ac375c9d 100644 (file)
@@ -1,9 +1,28 @@
 ACLOCAL_AMFLAGS = -I config
 
-SUBDIRS = lttng-consumerd
+SUBDIRS =
 
-if ! BUILD_CONSUMERD_ONLY
-SUBDIRS += lttng \
-           lttng-sessiond \
-           lttng-relayd
+# Make sure to always distribute all folders
+# since SUBDIRS is decided at configure time.
+DIST_SUBDIRS = lttng-consumerd lttng lttng-sessiond lttng-relayd \
+              lttng-crash
+
+if BUILD_BIN_LTTNG
+SUBDIRS += lttng
+endif
+
+if BUILD_BIN_LTTNG_CONSUMERD
+SUBDIRS += lttng-consumerd
+endif
+
+if BUILD_BIN_LTTNG_CRASH
+SUBDIRS += lttng-crash
+endif
+
+if BUILD_BIN_LTTNG_RELAYD
+SUBDIRS += lttng-relayd
+endif
+
+if BUILD_BIN_LTTNG_SESSIOND
+SUBDIRS += lttng-sessiond
 endif
This page took 0.022991 seconds and 4 git commands to generate.