Add epoll check to autoconf and Makefile
[lttng-tools.git] / ltt-sessiond / Makefile.am
index d19fe3caa7298d03e9eb511610f8f7e56d535c69..e1b42ca09ef6699ed46f31716417d74a55a47b2a 100644 (file)
@@ -5,6 +5,12 @@ AM_CFLAGS = -fno-strict-aliasing
 
 bin_PROGRAMS = ltt-sessiond
 
+if COMPAT_EPOLL
+COMPAT=compat-epoll.c
+else
+COMPAT=compat-poll.c
+endif
+
 ltt_sessiond_SOURCES = utils.c utils.h \
                        trace-kernel.c trace-kernel.h \
                        trace-ust.c trace-ust.h \
@@ -15,6 +21,8 @@ ltt_sessiond_SOURCES = utils.c utils.h \
                        context.c context.h \
                        futex.c futex.h \
                        shm.c shm.h \
+                       poll.h \
+                       $(COMPAT) \
                        session.c session.h \
                        ltt-sessiond.h main.c
 
This page took 0.022584 seconds and 4 git commands to generate.