Add UST trace data structure and functions
[lttng-tools.git] / ltt-sessiond / Makefile.am
index daa4265c1bda6e6ec7f210ec572980a25b0f7372..6cffbd738e06aead5fa803415f9de58258119a50 100644 (file)
@@ -1,15 +1,21 @@
 AM_CPPFLAGS = -I$(top_srcdir)/include \
-                         -I$(top_srcdir)/libkernelctl -I$(top_srcdir)/libustctl \
-                         -DINSTALL_BIN_PATH=\"$(bindir)\"
+                         -DINSTALL_BIN_PATH=\""$(bindir)"\"
 
 AM_CFLAGS = -fno-strict-aliasing
 
 bin_PROGRAMS = ltt-sessiond
 
-ltt_sessiond_SOURCES = utils.c trace.c session.c traceable-app.c ust-ctl.c \
-                       kernel-ctl.c context.c main.c \
-                       utils.h trace.h session.h traceable-app.h ust-ctl.h \
-                       context.h kernel-ctl.h ltt-sessiond.h
+ltt_sessiond_SOURCES = utils.c utils.h \
+                       trace-kernel.c trace-kernel.h \
+                       trace-ust.c trace-ust.h \
+                       session.c session.h \
+                       traceable-app.c traceable-app.h \
+                       ust-ctl.c ust-ctl.h \
+                       kernel-ctl.c kernel-ctl.h \
+                       context.c context.h \
+                       futex.c futex.h \
+                       ust-comm.c ust-comm.h \
+                       ltt-sessiond.h main.c
 
 # link on liblttngctl for check if sessiond is already alive.
 ltt_sessiond_LDADD = \
This page took 0.023023 seconds and 4 git commands to generate.