Add missing rculfhash.h header to make dist
[lttng-tools.git] / ltt-sessiond / Makefile.am
index d19fe3caa7298d03e9eb511610f8f7e56d535c69..5b70933719d356940386549c442bf463353374a7 100644 (file)
@@ -5,7 +5,14 @@ AM_CFLAGS = -fno-strict-aliasing
 
 bin_PROGRAMS = ltt-sessiond
 
+if COMPAT_EPOLL
+COMPAT=compat/compat-epoll.c
+else
+COMPAT=compat/compat-poll.c
+endif
+
 ltt_sessiond_SOURCES = utils.c utils.h \
+                       compat/poll.h $(COMPAT) \
                        trace-kernel.c trace-kernel.h \
                        trace-ust.c trace-ust.h \
                        traceable-app.c traceable-app.h \
@@ -13,10 +20,14 @@ ltt_sessiond_SOURCES = utils.c utils.h \
                        ust-ctl.c ust-ctl.h \
                        kernel-ctl.c kernel-ctl.h \
                        context.c context.h \
+                       channel.c channel.h \
+                       event.c event.h \
                        futex.c futex.h \
                        shm.c shm.h \
                        session.c session.h \
-                       ltt-sessiond.h main.c
+                       ltt-sessiond.h main.c \
+                       ../hashtable/rculfhash.c \
+                       ../hashtable/rculfhash.h
 
 # link on liblttngctl for check if sessiond is already alive.
 ltt_sessiond_LDADD = -lrt \
This page took 0.022682 seconds and 4 git commands to generate.