Add missing rculfhash.h header to make dist
[lttng-tools.git] / ltt-sessiond / Makefile.am
index 47930918948aa95537b218aeab41fffc47b04265..5b70933719d356940386549c442bf463353374a7 100644 (file)
@@ -1,8 +1,37 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/liblttsessiondcomm
+AM_CPPFLAGS = -I$(top_srcdir)/include \
+                         -DINSTALL_BIN_PATH=\""$(bindir)"\"
+
+AM_CFLAGS = -fno-strict-aliasing
 
 bin_PROGRAMS = ltt-sessiond
 
-ltt_sessiond_SOURCES = ltt-sessiond.c
+if COMPAT_EPOLL
+COMPAT=compat/compat-epoll.c
+else
+COMPAT=compat/compat-poll.c
+endif
+
+ltt_sessiond_SOURCES = utils.c utils.h \
+                       compat/poll.h $(COMPAT) \
+                       trace-kernel.c trace-kernel.h \
+                       trace-ust.c trace-ust.h \
+                       traceable-app.c traceable-app.h \
+                       ust-comm.c ust-comm.h \
+                       ust-ctl.c ust-ctl.h \
+                       kernel-ctl.c kernel-ctl.h \
+                       context.c context.h \
+                       channel.c channel.h \
+                       event.c event.h \
+                       futex.c futex.h \
+                       shm.c shm.h \
+                       session.c session.h \
+                       ltt-sessiond.h main.c \
+                       ../hashtable/rculfhash.c \
+                       ../hashtable/rculfhash.h
 
-ltt_sessiond_LDADD = \
-                $(top_builddir)/liblttsessiondcomm/liblttsessiondcomm.la
+# link on liblttngctl for check if sessiond is already alive.
+ltt_sessiond_LDADD = -lrt \
+                $(top_builddir)/liblttng-sessiond-comm/liblttng-sessiond-comm.la \
+                $(top_builddir)/libkernelctl/libkernelctl.la \
+                $(top_builddir)/libustctl/libustctl.la \
+                $(top_builddir)/liblttngctl/liblttngctl.la
This page took 0.023469 seconds and 4 git commands to generate.