Preliminary work for full UST support
[lttng-tools.git] / ltt-sessiond / Makefile.am
index f3723016ea083a731e4b79bfd535cc07eeb44789..4c23849cf85af96e8144684a4202c64e98be4563 100644 (file)
@@ -16,24 +16,24 @@ ltt_sessiond_SOURCES = utils.c utils.h \
                        compat/poll.h $(COMPAT) \
                        trace-kernel.c trace-kernel.h \
                        kernel-ctl.c kernel-ctl.h \
-                      ust-ctl.h ust-app.h trace-ust.h \
+                       ust-ctl.h ust-app.h trace-ust.h \
                        context.c context.h \
                        channel.c channel.h \
                        event.c event.h \
                        futex.c futex.h \
                        shm.c shm.h \
                        session.c session.h \
-                       ltt-sessiond.h main.c \
                        ../hashtable/rculfhash.c \
                        ../hashtable/rculfhash.h \
                        ../hashtable/hash.c ../hashtable/hash.h
 
 if LTTNG_TOOLS_HAVE_UST
-ltt_sessiond_SOURCES += \
-                       trace-ust.c \
-                       ust-app.c
+ltt_sessiond_SOURCES += trace-ust.c ust-app.c ust-consumer.c ust-consumer.h
 endif
 
+# Add main.c at the end for compile order
+ltt_sessiond_SOURCES += ltt-sessiond.h main.c
+
 # link on liblttngctl for check if sessiond is already alive.
 ltt_sessiond_LDADD = -lrt -lurcu-cds -lurcu \
                 $(top_builddir)/liblttng-sessiond-comm/liblttng-sessiond-comm.la \
This page took 0.022479 seconds and 4 git commands to generate.