Preliminary work for full UST support
[lttng-tools.git] / ltt-sessiond / Makefile.am
index 6cffbd738e06aead5fa803415f9de58258119a50..4c23849cf85af96e8144684a4202c64e98be4563 100644 (file)
@@ -5,21 +5,41 @@ AM_CFLAGS = -fno-strict-aliasing
 
 bin_PROGRAMS = ltt-sessiond
 
+if COMPAT_EPOLL
+COMPAT=compat/compat-epoll.c
+else
+COMPAT=compat/compat-poll.c
+endif
+
 ltt_sessiond_SOURCES = utils.c utils.h \
+                       hashtable.c hashtable.h \
+                       compat/poll.h $(COMPAT) \
                        trace-kernel.c trace-kernel.h \
-                       trace-ust.c trace-ust.h \
-                       session.c session.h \
-                       traceable-app.c traceable-app.h \
-                       ust-ctl.c ust-ctl.h \
                        kernel-ctl.c kernel-ctl.h \
+                       ust-ctl.h ust-app.h trace-ust.h \
                        context.c context.h \
+                       channel.c channel.h \
+                       event.c event.h \
                        futex.c futex.h \
-                       ust-comm.c ust-comm.h \
-                       ltt-sessiond.h main.c
+                       shm.c shm.h \
+                       session.c session.h \
+                       ../hashtable/rculfhash.c \
+                       ../hashtable/rculfhash.h \
+                       ../hashtable/hash.c ../hashtable/hash.h
+
+if LTTNG_TOOLS_HAVE_UST
+ltt_sessiond_SOURCES += trace-ust.c ust-app.c ust-consumer.c ust-consumer.h
+endif
+
+# Add main.c at the end for compile order
+ltt_sessiond_SOURCES += ltt-sessiond.h main.c
 
 # link on liblttngctl for check if sessiond is already alive.
-ltt_sessiond_LDADD = \
+ltt_sessiond_LDADD = -lrt -lurcu-cds -lurcu \
                 $(top_builddir)/liblttng-sessiond-comm/liblttng-sessiond-comm.la \
                 $(top_builddir)/libkernelctl/libkernelctl.la \
-                $(top_builddir)/libustctl/libustctl.la \
                 $(top_builddir)/liblttngctl/liblttngctl.la
+
+if LTTNG_TOOLS_HAVE_UST
+ltt_sessiond_LDADD += -llttng-ust-comm -lustctl
+endif
This page took 0.023033 seconds and 4 git commands to generate.