Fix handling of sessiond respawn after a SIGKILL
[lttng-tools.git] / ltt-sessiond / Makefile.am
index 9134a3e95cd7cf85bd2fad0c6018dc45d6f1cf31..26861735030c6c2706ac48bf857b19c853769820 100644 (file)
@@ -1,16 +1,19 @@
 AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/liblttsessiondcomm \
-                         -I$(top_srcdir)/libkernelctl -I$(top_srcdir)/libustctl
-
-INCLUDES = -DINSTALL_PATH=\""$(bindir)"\"
+                         -I$(top_srcdir)/libkernelctl -I$(top_srcdir)/libustctl \
+                         -DINSTALL_BIN_PATH=\"$(bindir)\"
 
 AM_CFLAGS = -fno-strict-aliasing
 
 bin_PROGRAMS = ltt-sessiond
 
-ltt_sessiond_SOURCES = utils.c trace.c session.c traceable-app.c ust-ctl.c kernel-ctl.c main.c \
-                       utils.h trace.h session.h traceable-app.h ust-ctl.h kernel-ctl.h ltt-sessiond.h
+ltt_sessiond_SOURCES = utils.c trace.c session.c traceable-app.c ust-ctl.c \
+                       kernel-ctl.c context.c main.c \
+                       utils.h trace.h session.h traceable-app.h ust-ctl.h \
+                       context.h kernel-ctl.h ltt-sessiond.h
 
+# link on liblttngctl for check if sessiond is already alive.
 ltt_sessiond_LDADD = \
                 $(top_builddir)/liblttsessiondcomm/liblttsessiondcomm.la \
                 $(top_builddir)/libkernelctl/libkernelctl.la \
-                $(top_builddir)/libustctl/libustctl.la
+                $(top_builddir)/libustctl/libustctl.la \
+                $(top_builddir)/liblttngctl/liblttngctl.la
This page took 0.022858 seconds and 4 git commands to generate.