Fix handling of sessiond respawn after a SIGKILL
[lttng-tools.git] / ltt-sessiond / Makefile.am
index 4d634a90a8d3b0cc03725a91b6695f74564746d1..26861735030c6c2706ac48bf857b19c853769820 100644 (file)
@@ -1,10 +1,19 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/liblttsessiondcomm -I$(top_srcdir)/libkernelctl
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/liblttsessiondcomm \
+                         -I$(top_srcdir)/libkernelctl -I$(top_srcdir)/libustctl \
+                         -DINSTALL_BIN_PATH=\"$(bindir)\"
+
 AM_CFLAGS = -fno-strict-aliasing
 
 bin_PROGRAMS = ltt-sessiond
 
-ltt_sessiond_SOURCES = session.c traceable-app.c ust-ctl.c kernel-ctl.c main.c
+ltt_sessiond_SOURCES = utils.c trace.c session.c traceable-app.c ust-ctl.c \
+                       kernel-ctl.c context.c main.c \
+                       utils.h trace.h session.h traceable-app.h ust-ctl.h \
+                       context.h kernel-ctl.h ltt-sessiond.h
 
+# link on liblttngctl for check if sessiond is already alive.
 ltt_sessiond_LDADD = \
                 $(top_builddir)/liblttsessiondcomm/liblttsessiondcomm.la \
-                $(top_builddir)/libkernelctl/libkernelctl.la
+                $(top_builddir)/libkernelctl/libkernelctl.la \
+                $(top_builddir)/libustctl/libustctl.la \
+                $(top_builddir)/liblttngctl/liblttngctl.la
This page took 0.024591 seconds and 4 git commands to generate.