Fix: Use result of AC_PROG_* when using sed / grep
[lttng-tools.git] / include / Makefile.am
index a30002e29253a084e313719c244189518e30b74e..fd9d8d02391a8db0232b9ac0c842791fdca76df9 100644 (file)
@@ -42,10 +42,10 @@ version.h:
                ## want to update the file if it is already up to date.
                ##
                version_match='^#define GIT_VERSION.*'; \
-               old_version=$$(grep "$${version_match}" "$${version_h}"); \
+               old_version=$$($(GREP) "$${version_match}" "$${version_h}"); \
                new_version="#define GIT_VERSION        \"$${git_version}\""; \
                if [ x"$${old_version}" != x"$${new_version}" ]; then \
-                       sed -i "s'$${version_match}'$${new_version}'" "$${version_h}"; \
+                       $(SED) -i "s'$${version_match}'$${new_version}'" "$${version_h}"; \
                else \
                        echo -n " (cached)"; \
                fi; \
This page took 0.0228 seconds and 4 git commands to generate.