actions: introduce start session action
[lttng-tools.git] / include / Makefile.am
index 79597f4f2bc81984819bbc88dd7d5852010c1c4d..dace86e032831cb797e0f6ee683959a480762719 100644 (file)
@@ -1,3 +1,4 @@
+## SPDX-License-Identifier: GPL-2.0-only
 ##
 ## This target generates an include file that contains the git version
 ## string of the current branch, it must be continuously updated when
@@ -51,6 +52,9 @@ version_verbose_0 = @echo "  GEN       " $@;
 
 version.i:
        $(version_verbose)rm -f version.i.tmp; \
+       if (test ! -f version.i && test -f "$(top_srcdir)/include/version.i"); then \
+               cp "$(top_srcdir)/include/version.i" version.i; \
+       fi; \
        if (test -r "$(top_srcdir)/bootstrap" && test -r "$(top_srcdir)/.git") && \
                        test -x "`which git 2>&1;true`"; then \
                GIT_VERSION_STR="`cd "$(top_srcdir)" && git describe --tags --dirty`"; \
@@ -110,11 +114,15 @@ lttnginclude_HEADERS = \
        lttng/location.h \
        lttng/userspace-probe.h \
        lttng/session-descriptor.h \
-       lttng/destruction-handle.h
+       lttng/destruction-handle.h \
+       lttng/clear.h \
+       lttng/clear-handle.h \
+       lttng/tracker.h
 
 lttngactioninclude_HEADERS= \
        lttng/action/action.h \
-       lttng/action/notify.h
+       lttng/action/notify.h \
+       lttng/action/start-session.h
 
 lttngconditioninclude_HEADERS= \
        lttng/condition/condition.h \
@@ -137,6 +145,7 @@ noinst_HEADERS = \
        lttng/load-internal.h \
        lttng/action/action-internal.h \
        lttng/action/notify-internal.h \
+       lttng/action/start-session-internal.h \
        lttng/condition/condition-internal.h \
        lttng/condition/buffer-usage-internal.h \
        lttng/condition/session-consumed-size-internal.h \
This page took 0.022968 seconds and 4 git commands to generate.