Add --disable-git-version to configure
[lttng-tools.git] / include / Makefile.am
index 24f2f57aa2479a22093fdf802b290539cd6afd4e..d2061f1e05ea75bb7db8fd542dc683d19253bdca 100644 (file)
@@ -9,7 +9,7 @@ version.h:
        ## the locations of the version.h and version.h.tmpl files
        ##
        @echo -n "Generating version.h ... "
-       @(version_h_tmpl="$(top_builddir)/include/version.h.tmpl"; \
+       @(version_h_tmpl="$(top_srcdir)/include/version.h.tmpl"; \
        if [ -f "$${version_h_tmpl}" ]; then \
                version_h="$(top_builddir)/include/version.h"; \
                ##
@@ -46,20 +46,8 @@ version.h:
                        ## as the one currently in the file (if there is one), as we
                        ## don't want to update the file if it is already up to date
                        ##
-                       if [ $$(grep -cE "^#define GIT_VERSION \"?$${git_version}\"?$$" "$${version_h}") -eq 0 ]; then \
-                               if [ $$(grep -c "^#define GIT_VERSION" "$${version_h}") -gt 0 ]; then \
-                                       ##
-                                       ## If there is already a GIT_VERSION defined,
-                                       ## we just replace it by the new version
-                                       ##
-                                       sed -i "s'^#define GIT_VERSION.*$$'#define GIT_VERSION \"$${git_version}\"'" "$${version_h}"; \
-                               else \
-                                       ##
-                                       ## Else, we add a GIT_VERSION define
-                                       ## containing our new version.
-                                       ##
-                                       sed -i "s'^\(#define VERSION_H.*\)$$'\1\n\n#define GIT_VERSION \"$${git_version}\"'" "$${version_h}"; \
-                               fi; \
+                       if [ $$(grep -cE "^#define GIT_VERSION_SED \"?$${git_version}\"?$$" "$${version_h}") -eq 0 ]; then \
+                               sed -i "s'^#define GIT_VERSION_SED.*$$'#define GIT_VERSION \"$${git_version}\"'" "$${version_h}"; \
                        fi; \
                fi; \
        fi)
@@ -74,12 +62,20 @@ version.h:
 lttnginclude_HEADERS = \
        lttng/health.h \
        lttng/lttng.h \
+       lttng/constant.h \
+       lttng/channel.h \
+       lttng/domain.h \
+       lttng/event.h \
+       lttng/handle.h \
+       lttng/session.h \
        lttng/lttng-error.h \
        lttng/snapshot.h \
        lttng/save.h \
+       lttng/load.h \
        version.h
 
 noinst_HEADERS = \
        lttng/snapshot-internal.h \
        lttng/health-internal.h \
-       lttng/save-internal.h
+       lttng/save-internal.h \
+       lttng/load-internal.h
This page took 0.023481 seconds and 4 git commands to generate.