Clean-up: kernel consumer: change spaces to tabs
[lttng-tools.git] / include / Makefile.am
index 25d0dc8dd15c37481183aa0497b49a1b234c1a41..baad620dda6bd0bafb5c1c498aa0f133c853111e 100644 (file)
@@ -1,3 +1,4 @@
+## SPDX-License-Identifier: GPL-2.0-only
 ##
 ## This target generates an include file that contains the git version
 ## string of the current branch, it must be continuously updated when
 ## overwrite the git version with an empty string in "version.i.tmp".
 ##
 ## If we don't have a "version.i.tmp" nor a "version.i", generate an empty
-## string as a failover.
+## string as a failover. If a "version.i" is present, for example when building
+## from a distribution tarball, get the git_version using grep.
 ##
-## If we don't have a "version.i" or we have both files and they are different,
-## copy "version.i.tmp" over "version.i". This way the dependent targets are
-## only rebuilt when the version string changes.
+## Fetch the EXTRA_VERSION_NAME define from "version/extra_version_name" and output it
+## to "version.i.tmp".
+##
+## Fetch the EXTRA_VERSION_DESCRIPTION define from "version/extra_version_description",
+## sanitize and format it with a sed script to replace all non-alpha-numeric values
+## with "-" and join all lines by replacing "\n" with litteral string c-style "\n\t" and
+## output it to "version.i.tmp".
+##
+## Repeat the same logic for the "version/extra_patches" directory.
+## Data fetched from "version/extra_patches" must be sanitized and
+## formatted.
+## The data is fetched using "ls" with an ignore pattern for the README file.
+## The sanitize step uses sed with a script to replace all
+## non-alpha-numeric values, except " " (space), to "-".
+## The formatting step uses sed with a script to join all lines
+## by replacing "\n" with litteral string c-style "\n\t".
+##
+## If we don't have a "version.i" or we have both files (version.i, version.i.tmp)
+## and they are different, copy "version.i.tmp" over "version.i".
+## This way the dependent targets are only rebuilt when the git version
+## string or either one of extra version string change.
 ##
 version_verbose = $(version_verbose_@AM_V@)
 version_verbose_ = $(version_verbose_@AM_DEFAULT_V@)
@@ -32,6 +52,9 @@ version_verbose_0 = @echo "  GEN       " $@;
 
 version.i:
        $(version_verbose)rm -f version.i.tmp; \
+       if (test ! -f version.i && test -f "$(top_srcdir)/include/version.i"); then \
+               cp "$(top_srcdir)/include/version.i" version.i; \
+       fi; \
        if (test -r "$(top_srcdir)/bootstrap" && test -r "$(top_srcdir)/.git") && \
                        test -x "`which git 2>&1;true`"; then \
                GIT_VERSION_STR="`cd "$(top_srcdir)" && git describe --tags --dirty`"; \
@@ -43,10 +66,16 @@ version.i:
                fi; \
        fi; \
        if test ! -f version.i.tmp; then \
-               if test ! -f version.i; then \
-                       echo '#define GIT_VERSION ""' > version.i; \
+               if test -f version.i; then \
+                       $(GREP) "^#define \bGIT_VERSION\b.*" version.i > version.i.tmp; \
+               else \
+                       echo '#define GIT_VERSION ""' > version.i.tmp; \
                fi; \
-       elif test ! -f version.i || \
+       fi; \
+       echo "#define EXTRA_VERSION_NAME \"`$(SED) -n '1p' "$(top_srcdir)/version/extra_version_name" 2> /dev/null`\"" >> version.i.tmp; \
+       echo "#define EXTRA_VERSION_DESCRIPTION \"`$(SED) -E ':a ; N ; $$!ba ; s/[^a-zA-Z0-9 \n\t\.,]/-/g ; s/\r{0,1}\n/\\\n\\\t/g' "$(top_srcdir)/version/extra_version_description" 2> /dev/null`\"" >> version.i.tmp; \
+       echo "#define EXTRA_VERSION_PATCHES \"`ls --ignore='README' -1 "$(top_srcdir)/version/extra_patches" | $(SED) -E ':a ; N ; $$!ba ; s/[^a-zA-Z0-9 \n\t\.]/-/g ; s/\r{0,1}\n/\\\n\\\t/g' 2> /dev/null`\"" >> version.i.tmp; \
+       if test ! -f version.i || \
                        test x"`cat version.i.tmp`" != x"`cat version.i`"; then \
                mv version.i.tmp version.i; \
        fi; \
@@ -82,11 +111,22 @@ lttnginclude_HEADERS = \
        lttng/load.h \
        lttng/endpoint.h \
        lttng/rotation.h \
-       lttng/location.h
+       lttng/location.h \
+       lttng/userspace-probe.h \
+       lttng/session-descriptor.h \
+       lttng/destruction-handle.h \
+       lttng/clear.h \
+       lttng/clear-handle.h \
+       lttng/tracker.h
 
 lttngactioninclude_HEADERS= \
        lttng/action/action.h \
-       lttng/action/notify.h
+       lttng/action/group.h \
+       lttng/action/notify.h \
+       lttng/action/rotate-session.h \
+       lttng/action/snapshot-session.h \
+       lttng/action/start-session.h \
+       lttng/action/stop-session.h
 
 lttngconditioninclude_HEADERS= \
        lttng/condition/condition.h \
@@ -108,7 +148,12 @@ noinst_HEADERS = \
        lttng/save-internal.h \
        lttng/load-internal.h \
        lttng/action/action-internal.h \
+       lttng/action/group-internal.h \
        lttng/action/notify-internal.h \
+       lttng/action/rotate-session-internal.h \
+       lttng/action/snapshot-session-internal.h \
+       lttng/action/start-session-internal.h \
+       lttng/action/stop-session-internal.h \
        lttng/condition/condition-internal.h \
        lttng/condition/buffer-usage-internal.h \
        lttng/condition/session-consumed-size-internal.h \
@@ -123,5 +168,8 @@ noinst_HEADERS = \
        lttng/rotate-internal.h \
        lttng/ref-internal.h \
        lttng/location-internal.h \
+       lttng/userspace-probe-internal.h \
+       lttng/session-internal.h \
+       lttng/session-descriptor-internal.h \
        version.h \
        version.i
This page took 0.024161 seconds and 4 git commands to generate.