lttng: Add list-triggers command
[lttng-tools.git] / include / Makefile.am
index fe83588cafcb1311a14d325449d2535c4d2d6698..957a01d25d171ed1000a099f6ec1dbb7a3002d02 100644 (file)
@@ -74,7 +74,7 @@ version.i:
        fi; \
        echo "#define EXTRA_VERSION_NAME \"`$(SED) -n '1p' "$(top_srcdir)/version/extra_version_name" 2> /dev/null`\"" >> version.i.tmp; \
        echo "#define EXTRA_VERSION_DESCRIPTION \"`$(SED) -E ':a ; N ; $$!ba ; s/[^a-zA-Z0-9 \n\t\.,]/-/g ; s/\r{0,1}\n/\\\n\\\t/g' "$(top_srcdir)/version/extra_version_description" 2> /dev/null`\"" >> version.i.tmp; \
-       echo "#define EXTRA_VERSION_PATCHES \"`ls --ignore='README' -1 "$(top_srcdir)/version/extra_patches" | $(SED) -E ':a ; N ; $$!ba ; s/[^a-zA-Z0-9 \n\t\.]/-/g ; s/\r{0,1}\n/\\\n\\\t/g' 2> /dev/null`\"" >> version.i.tmp; \
+       echo "#define EXTRA_VERSION_PATCHES \"`ls -1 "$(top_srcdir)/version/extra_patches" | $(GREP) -v '^README' | $(SED) -E ':a ; N ; $$!ba ; s/[^a-zA-Z0-9 \n\t\.]/-/g ; s/\r{0,1}\n/\\\n\\\t/g' 2> /dev/null`\"" >> version.i.tmp; \
        if test ! -f version.i || \
                        test x"`cat version.i.tmp`" != x"`cat version.i`"; then \
                mv version.i.tmp version.i; \
@@ -132,6 +132,7 @@ lttngactioninclude_HEADERS= \
 lttngconditioninclude_HEADERS= \
        lttng/condition/condition.h \
        lttng/condition/buffer-usage.h \
+       lttng/condition/event-rule.h \
        lttng/condition/session-consumed-size.h \
        lttng/condition/session-rotation.h \
        lttng/condition/evaluation.h
@@ -144,7 +145,11 @@ lttngtriggerinclude_HEADERS= \
        lttng/trigger/trigger.h
 
 lttngeventruleinclude_HEADERS= \
-       lttng/event-rule/event-rule.h
+       lttng/event-rule/event-rule.h \
+       lttng/event-rule/kprobe.h \
+       lttng/event-rule/syscall.h \
+       lttng/event-rule/uprobe.h \
+       lttng/event-rule/tracepoint.h
 
 noinst_HEADERS = \
        lttng/snapshot-internal.h \
@@ -160,6 +165,7 @@ noinst_HEADERS = \
        lttng/action/stop-session-internal.h \
        lttng/condition/condition-internal.h \
        lttng/condition/buffer-usage-internal.h \
+       lttng/condition/event-rule-internal.h \
        lttng/condition/session-consumed-size-internal.h \
        lttng/condition/evaluation-internal.h \
        lttng/condition/session-rotation-internal.h \
@@ -168,6 +174,7 @@ noinst_HEADERS = \
        lttng/endpoint-internal.h \
        lttng/notification/channel-internal.h \
        lttng/channel-internal.h \
+       lttng/domain-internal.h \
        lttng/event-internal.h \
        lttng/rotate-internal.h \
        lttng/ref-internal.h \
@@ -177,5 +184,9 @@ noinst_HEADERS = \
        lttng/session-descriptor-internal.h \
        lttng/kernel-probe-internal.h \
        lttng/event-rule/event-rule-internal.h \
+       lttng/event-rule/kprobe-internal.h \
+       lttng/event-rule/syscall-internal.h \
+       lttng/event-rule/uprobe-internal.h \
+       lttng/event-rule/tracepoint-internal.h \
        version.h \
        version.i
This page took 0.02346 seconds and 4 git commands to generate.