Introduce lttng_domain_type_str utility
[lttng-tools.git] / include / Makefile.am
index fe83588cafcb1311a14d325449d2535c4d2d6698..5a3b5b5f3bbcfdbfcf49628d0c28d3091d27f2f2 100644 (file)
@@ -74,7 +74,7 @@ version.i:
        fi; \
        echo "#define EXTRA_VERSION_NAME \"`$(SED) -n '1p' "$(top_srcdir)/version/extra_version_name" 2> /dev/null`\"" >> version.i.tmp; \
        echo "#define EXTRA_VERSION_DESCRIPTION \"`$(SED) -E ':a ; N ; $$!ba ; s/[^a-zA-Z0-9 \n\t\.,]/-/g ; s/\r{0,1}\n/\\\n\\\t/g' "$(top_srcdir)/version/extra_version_description" 2> /dev/null`\"" >> version.i.tmp; \
-       echo "#define EXTRA_VERSION_PATCHES \"`ls --ignore='README' -1 "$(top_srcdir)/version/extra_patches" | $(SED) -E ':a ; N ; $$!ba ; s/[^a-zA-Z0-9 \n\t\.]/-/g ; s/\r{0,1}\n/\\\n\\\t/g' 2> /dev/null`\"" >> version.i.tmp; \
+       echo "#define EXTRA_VERSION_PATCHES \"`ls -1 "$(top_srcdir)/version/extra_patches" | $(GREP) -v '^README' | $(SED) -E ':a ; N ; $$!ba ; s/[^a-zA-Z0-9 \n\t\.]/-/g ; s/\r{0,1}\n/\\\n\\\t/g' 2> /dev/null`\"" >> version.i.tmp; \
        if test ! -f version.i || \
                        test x"`cat version.i.tmp`" != x"`cat version.i`"; then \
                mv version.i.tmp version.i; \
@@ -144,7 +144,11 @@ lttngtriggerinclude_HEADERS= \
        lttng/trigger/trigger.h
 
 lttngeventruleinclude_HEADERS= \
-       lttng/event-rule/event-rule.h
+       lttng/event-rule/event-rule.h \
+       lttng/event-rule/kprobe.h \
+       lttng/event-rule/syscall.h \
+       lttng/event-rule/uprobe.h \
+       lttng/event-rule/tracepoint.h
 
 noinst_HEADERS = \
        lttng/snapshot-internal.h \
@@ -168,6 +172,7 @@ noinst_HEADERS = \
        lttng/endpoint-internal.h \
        lttng/notification/channel-internal.h \
        lttng/channel-internal.h \
+       lttng/domain-internal.h \
        lttng/event-internal.h \
        lttng/rotate-internal.h \
        lttng/ref-internal.h \
@@ -177,5 +182,9 @@ noinst_HEADERS = \
        lttng/session-descriptor-internal.h \
        lttng/kernel-probe-internal.h \
        lttng/event-rule/event-rule-internal.h \
+       lttng/event-rule/kprobe-internal.h \
+       lttng/event-rule/syscall-internal.h \
+       lttng/event-rule/uprobe-internal.h \
+       lttng/event-rule/tracepoint-internal.h \
        version.h \
        version.i
This page took 0.024152 seconds and 4 git commands to generate.