Extras: Fix the undefined reference to md build error.
[lttng-tools.git] / extras / bindings / swig / python / Makefile.am
index a3557b8b076aac7dbdae782bc810b59896840ddb..c6a69010eadfefdef7622874f725634ea43fa20f 100644 (file)
@@ -17,11 +17,7 @@ _lttng_la_LDFLAGS = -module
 _lttng_la_LIBADD =     $(top_srcdir)/src/lib/lttng-ctl/liblttng-ctl.la                 \
                        $(top_srcdir)/src/common/sessiond-comm/libsessiond-comm.la
 
-# SWIG 'warning md variable unused' fixed after SWIG build:
 lttng_wrap.c: lttng.i
        $(SWIG) -python -I. -I$(top_srcdir)/src/common/sessiond-comm lttng.i
-       sed -i "s/PyObject \*m, \*d, \*md;/PyObject \*m, \*d;\n#if defined(SWIGPYTHON_BUILTIN)\nPyObject *md;\n#endif/g" lttng_wrap.c
-       sed -i "s/md = d/d/g" lttng_wrap.c
-       sed -i "s/(void)public_symbol;/(void)public_symbol;\n  md = d;/g" lttng_wrap.c
 
-CLEANFILES = lttng.i lttng.py lttng_wrap.c
+CLEANFILES = lttng.i lttng.py lttng_wrap.c lttng.pyc
This page took 0.022995 seconds and 4 git commands to generate.