Fix: mark generated python bindings files as nodist
[lttng-tools.git] / extras / bindings / swig / python / Makefile.am
index d592dedb3a2182e163c9631b658af9a9d8af0339..6e7baa69d86fc8eb3ef6bc576859d62ef0607a9a 100644 (file)
@@ -4,24 +4,18 @@ lttng.i: lttng.i.in
 AM_CFLAGS = -I$(PYTHON_INCLUDE) -I$(top_srcdir)/lib/lttng-ctl -I../common \
               $(BUDDY_CFLAGS)
 
-EXTRA_DIST = lttng.i
-python_PYTHON = lttng.py
+EXTRA_DIST = lttng.i.in
+nodist_python_PYTHON = lttng.py
 pyexec_LTLIBRARIES = _lttng.la
 
 MAINTAINERCLEANFILES = lttng_wrap.c lttng.py
 
-_lttng_la_SOURCES = lttng_wrap.c
-
+nodist__lttng_la_SOURCES = lttng_wrap.c
 _lttng_la_LDFLAGS = -module
-
 _lttng_la_LIBADD =     $(top_srcdir)/src/lib/lttng-ctl/liblttng-ctl.la                 \
                        $(top_srcdir)/src/common/sessiond-comm/libsessiond-comm.la
 
-# SWIG 'warning md variable unused' fixed after SWIG build:
 lttng_wrap.c: lttng.i
        $(SWIG) -python -I. -I$(top_srcdir)/src/common/sessiond-comm lttng.i
-       sed -i "s/PyObject \*m, \*d, \*md;/PyObject \*m, \*d;\n#if defined(SWIGPYTHON_BUILTIN)\nPyObject *md;\n#endif/g" lttng_wrap.c
-       sed -i "s/md = d/d/g" lttng_wrap.c
-       sed -i "s/(void)public_symbol;/(void)public_symbol;\n  md = d;/g" lttng_wrap.c
 
 CLEANFILES = lttng.i lttng.py lttng_wrap.c lttng.pyc
This page took 0.023044 seconds and 4 git commands to generate.