Add support for UST application registration
[lttng-tools.git] / configure.ac
index 066c4e20e3cc5ed293ca631428f86683c4294a78..02698885375515674b0ee2f68795dbd5dd67c05f 100644 (file)
@@ -22,11 +22,16 @@ AC_CHECK_LIB([popt], [poptGetContext], [],
        [AC_MSG_ERROR([Cannot find libpopt. Use [LDFLAGS]=-Ldir to specify its location.])]
 )
 
-# Check liburcu
+# Check liburcu list.h
 AC_CHECK_DECL([cds_list_add], [],
        [AC_MSG_ERROR([liburcu 0.5.4 or newer is needed])], [[#include <urcu/list.h>]]
 )
 
+# Check liburcu wfqueue.h
+AC_CHECK_DECL([cds_wfq_init], [],
+       [AC_MSG_ERROR([liburcu 0.5.4 or newer is needed])], [[#include <urcu/wfqueue.h>]]
+)
+
 AC_PROG_CC
 AC_PROG_LIBTOOL
 
This page took 0.030745 seconds and 4 git commands to generate.