Update documentation following babeltrace UI change
[lttng-tools.git] / configure.ac
CommitLineData
ab7f4103 1AC_INIT([lttng-tools], [2.0-pre14], [david.goulet@polymtl.ca], ,[http://lttng.org])
fac6795d 2AC_CONFIG_AUX_DIR([config])
6e2d116c
DG
3AC_CANONICAL_TARGET
4AC_CANONICAL_HOST
fac6795d 5AC_CONFIG_MACRO_DIR([config])
0403d7c9 6AM_INIT_AUTOMAKE([foreign dist-bzip2 no-dist-gzip])
fac6795d
DG
7AM_SILENT_RULES([yes])
8
3bd1e081
MD
9AC_CONFIG_HEADERS([include/config.h])
10
11AH_TEMPLATE([CONFIG_LTTNG_TOOLS_HAVE_UST], [Defined on systems where UST headers can be found.])
12
fac6795d
DG
13AC_CHECK_HEADERS([ \
14 sys/types.h unistd.h fcntl.h string.h pthread.h limits.h \
15 signal.h stdlib.h sys/un.h sys/socket.h stdlib.h stdio.h \
16 getopt.h sys/ipc.h sys/shm.h popt.h grp.h \
17])
18
8e12081b 19# URCU library version needed or newer
3ffccaed 20liburcu_version=">= 0.6.5"
8e12081b 21
fac6795d
DG
22# Check for pthread
23AC_CHECK_LIB([pthread], [pthread_create], [],
24 [AC_MSG_ERROR([Cannot find libpthread. Use [LDFLAGS]=-Ldir to specify its location.])]
25)
26
27# Check libpopt
28AC_CHECK_LIB([popt], [poptGetContext], [],
29 [AC_MSG_ERROR([Cannot find libpopt. Use [LDFLAGS]=-Ldir to specify its location.])]
30)
31
3ffccaed 32# Check liburcu needed function calls
fac6795d 33AC_CHECK_DECL([cds_list_add], [],
8e12081b 34 [AC_MSG_ERROR([liburcu $liburcu_version or newer is needed])], [[#include <urcu/list.h>]]
fac6795d 35)
099e26bd 36AC_CHECK_DECL([cds_wfq_init], [],
8e12081b
DG
37 [AC_MSG_ERROR([liburcu $liburcu_version or newer is needed])], [[#include <urcu/wfqueue.h>]]
38)
8e12081b
DG
39AC_CHECK_DECL([futex_async], [],
40 [AC_MSG_ERROR([liburcu $liburcu_version or newer is needed])], [[#include <urcu/futex.h>]]
099e26bd 41)
3ffccaed
DG
42AC_CHECK_DECL([rcu_thread_offline], [],
43 [AC_MSG_ERROR([liburcu $liburcu_version or newer is needed])], [[#include <urcu.h>]]
44)
45AC_CHECK_DECL([rcu_thread_online], [],
46 [AC_MSG_ERROR([liburcu $liburcu_version or newer is needed])], [[#include <urcu.h>]]
47)
3bd1e081
MD
48AC_CHECK_DECL([ustctl_create_session],
49 [
50 AC_DEFINE([CONFIG_LTTNG_TOOLS_HAVE_UST], 1)
51 have_ust_test=1
52 ],
53 [
54 AC_MSG_WARN([UST header not found. Building without UST support.])
55 have_ust_test=0
56 ],
57 [[#include <ust/lttng-ust-ctl.h>]]
58)
59
60AM_CONDITIONAL([LTTNG_TOOLS_HAVE_UST], [ test "x$have_ust_test" = "x1" ])
099e26bd 61
3ffccaed 62# Epoll check. If not present, the build will fallback on poll() API
71615260
DG
63AX_HAVE_EPOLL(
64 [AX_CONFIG_FEATURE_ENABLE(epoll)],
65 [AX_CONFIG_FEATURE_DISABLE(epoll)]
66)
71615260
DG
67AX_CONFIG_FEATURE(
68 [epoll], [This platform supports epoll(7)],
69 [HAVE_EPOLL], [This platform supports epoll(7).],
70 [enable_epoll="yes"], [enable_epoll="no"]
71)
71615260
DG
72AM_CONDITIONAL([COMPAT_EPOLL], [ test "$enable_epoll" = "yes" ])
73
fac6795d
DG
74AC_PROG_CC
75AC_PROG_LIBTOOL
76
6e2d116c
DG
77CFLAGS="-Wall $CFLAGS -g -fno-strict-aliasing"
78
79DEFAULT_INCLUDES="-I\$(top_srcdir) -I\$(top_builddir)"
80
81lttngincludedir="${includedir}/lttng"
82
83AC_SUBST(lttngincludedir)
84AC_SUBST(DEFAULT_INCLUDES)
85
fac6795d
DG
86AC_CONFIG_FILES([
87 Makefile
88 include/Makefile
ee0326c0 89 libkernelctl/Makefile
3bd1e081
MD
90 liblttng-consumer/Makefile
91 liblttng-kconsumer/Makefile
92 liblttng-ustconsumer/Makefile
fac6795d 93 liblttngctl/Makefile
ca3c5ac0 94 liblttng-sessiond-comm/Makefile
62d3069f 95 libustcomm/Makefile
3bd1e081 96 lttng-consumerd/Makefile
6e0ca3c2 97 ltt-sessiond/Makefile
fac6795d
DG
98 lttng/Makefile
99 tests/Makefile
ebb6ebd5 100 doc/Makefile
fac6795d
DG
101])
102
103AC_OUTPUT
This page took 0.04162 seconds and 4 git commands to generate.