Add kretprobe support (new --function implementation)
[lttng-tools.git] / configure.ac
CommitLineData
52ffda46 1AC_INIT([lttng-tools], [2.0-pre5], [david.goulet@polymtl.ca], ,[http://lttng.org])
fac6795d 2AC_CONFIG_AUX_DIR([config])
6e2d116c
DG
3AC_CANONICAL_TARGET
4AC_CANONICAL_HOST
fac6795d 5AC_CONFIG_MACRO_DIR([config])
0403d7c9 6AM_INIT_AUTOMAKE([foreign dist-bzip2 no-dist-gzip])
fac6795d
DG
7AM_SILENT_RULES([yes])
8
9AC_CHECK_HEADERS([ \
10 sys/types.h unistd.h fcntl.h string.h pthread.h limits.h \
11 signal.h stdlib.h sys/un.h sys/socket.h stdlib.h stdio.h \
12 getopt.h sys/ipc.h sys/shm.h popt.h grp.h \
13])
14
15# Check for pthread
16AC_CHECK_LIB([pthread], [pthread_create], [],
17 [AC_MSG_ERROR([Cannot find libpthread. Use [LDFLAGS]=-Ldir to specify its location.])]
18)
19
20# Check libpopt
21AC_CHECK_LIB([popt], [poptGetContext], [],
22 [AC_MSG_ERROR([Cannot find libpopt. Use [LDFLAGS]=-Ldir to specify its location.])]
23)
24
fac6795d 25# Check liburcu
fac6795d
DG
26AC_CHECK_DECL([cds_list_add], [],
27 [AC_MSG_ERROR([liburcu 0.5.4 or newer is needed])], [[#include <urcu/list.h>]]
28)
29
fac6795d
DG
30AC_PROG_CC
31AC_PROG_LIBTOOL
32
6e2d116c
DG
33CFLAGS="-Wall $CFLAGS -g -fno-strict-aliasing"
34
35DEFAULT_INCLUDES="-I\$(top_srcdir) -I\$(top_builddir)"
36
37lttngincludedir="${includedir}/lttng"
38
39AC_SUBST(lttngincludedir)
40AC_SUBST(DEFAULT_INCLUDES)
41
fac6795d
DG
42AC_CONFIG_FILES([
43 Makefile
44 include/Makefile
ee0326c0 45 libkernelctl/Makefile
1ce86c9a 46 liblttkconsumerd/Makefile
fac6795d
DG
47 liblttngctl/Makefile
48 liblttsessiondcomm/Makefile
62d3069f
DG
49 libustctl/Makefile
50 libustcomm/Makefile
2b1173d8 51 ltt-kconsumerd/Makefile
6e0ca3c2 52 ltt-sessiond/Makefile
fac6795d
DG
53 lttng/Makefile
54 tests/Makefile
ebb6ebd5 55 doc/Makefile
fac6795d
DG
56])
57
58AC_OUTPUT
This page took 0.034677 seconds and 4 git commands to generate.