Fix tracepoint test with deprecated API
[ust.git] / tests / tracepoint / Makefile.am
index 3c3fe90d2db36a983bbc1c862843d6ab045468e3..90ff28761642b32fc1d5b3c866abee5943def50e 100644 (file)
@@ -2,13 +2,10 @@ SUBDIRS = benchmark
 
 AM_CPPFLAGS = -I$(top_srcdir)/include
 
-#noinst_PROGRAMS = tracepoint_test
-#tracepoint_test_SOURCES = tracepoint_test.c tracepoint_test.h
-#tracepoint_test_LDADD = $(top_builddir)/libust/libust.la $(top_builddir)/libust-initializer.o
+noinst_PROGRAMS = tracepoint_test
+tracepoint_test_SOURCES = tracepoint_test.c tracepoint_test.h
+tracepoint_test_LDADD = $(top_builddir)/libust/libust.la $(top_builddir)/libust-initializer.o
 
-#FIXME: this test is broken:
-#ust/tests/tracepoint/tracepoint_test.c:64: undefined reference to
-#`register_trace_ust_event_msg'
-#CFLAGS_tracepoint_test.o = -I$(src)
+CFLAGS_tracepoint_test.o = -I$(src)
 noinst_SCRIPTS = run
 EXTRA_DIST = run
This page took 0.022145 seconds and 4 git commands to generate.