use signal safe ust_safe_snprintf()
[ust.git] / snprintf / Makefile.am
diff --git a/snprintf/Makefile.am b/snprintf/Makefile.am
new file mode 100644 (file)
index 0000000..1bd33fa
--- /dev/null
@@ -0,0 +1,22 @@
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/libustcomm
+
+lib_LTLIBRARIES = libustsnprintf.la
+libustsnprintf_la_SOURCES = \
+       fflush.c \
+       fileext.h \
+       floatio.h \
+       fvwrite.c \
+       fvwrite.h \
+       local.h \
+       snprintf.c \
+       various.h \
+       vfprintf.c \
+       wcio.h \
+       wsetup.c
+libustsnprintf_la_LDFLAGS = -no-undefined -version-info 0:0:0 -static
+libustsnprintf_la_CFLAGS = -DUST_COMPONENT="ust_snprintf" -fPIC
+
+check_PROGRAMS = prog
+prog_SOURCES = prog.c
+prog_LDADD = libustsnprintf.la
+TESTS = prog
This page took 0.022627 seconds and 4 git commands to generate.