Add ust java bindings
[ust.git] / java / Makefile.am
diff --git a/java/Makefile.am b/java/Makefile.am
new file mode 100644 (file)
index 0000000..e818b81
--- /dev/null
@@ -0,0 +1,15 @@
+INCLUDES = -I$(top_builddir)/share -I$(top_builddir)/libust $(KCOMPAT_CFLAGS) $(URCU_CFLAGS)
+
+lib_LTLIBRARIES = libustjava.la
+libustjava_la_SOURCES = UST.c UST.h
+noinst_DATA = UST.java
+libustjava_la_LIBADD = -lc -L$(top_builddir)/libust/.libs -lust
+
+all: UST.class
+
+clean-local:
+       rm -rf UST.h UST.class
+
+UST.class: UST.java
+       javac UST.java
+
This page took 0.021957 seconds and 4 git commands to generate.