Fix: lttng-gen-tp to build out of tree
[lttng-ust.git] / tools / Makefile.am
index 4ea75331596e19e1973b99a8cf0644e9a1653952..1bdd3f8a4ee2b3a89bc3bccb2fdd941fe4fc46fd 100644 (file)
@@ -1 +1,16 @@
 dist_bin_SCRIPTS = lttng-gen-tp
+EXTRA_DIST = lttng-gen-tp
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.024457 seconds and 4 git commands to generate.