Fix: Conditionally disable tests requiring shared libs support
[lttng-ust.git] / tests / demo / Makefile.am
index 0e432552a61a01229da72cdcdf60ab7c7772ecaf..76ab5989a7c7ed18b44b2acfa055447dc518169b 100644 (file)
@@ -6,6 +6,10 @@ AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include -Wsystem-headers
 # libraries.
 LIBS =
 
+if NO_SHARED
+# Do not build this test if shared libraries support was
+# explicitly disabled.
+else
 # Force the shared flag on the noinst libraries since they are
 # only built static by default
 FORCE_SHARED_LIB_OPTIONS = -module -shared -avoid-version \
@@ -41,3 +45,4 @@ if LTTNG_UST_BUILD_WITH_LIBC_DL
 demo_LDADD = -lc
 endif
 
+endif
This page took 0.023431 seconds and 4 git commands to generate.