Move current compile tests to 'api1'
[lttng-ust.git] / tests / compile / api1 / same_line_tracepoint / Makefile.am
diff --git a/tests/compile/api1/same_line_tracepoint/Makefile.am b/tests/compile/api1/same_line_tracepoint/Makefile.am
new file mode 100644 (file)
index 0000000..890ce48
--- /dev/null
@@ -0,0 +1,19 @@
+# SPDX-License-Identifier: LGPL-2.1-only
+
+AM_CPPFLAGS += -I$(srcdir)
+
+noinst_PROGRAMS = same_line_tracepoint same_line_tracepoint_compatapi1
+
+same_line_tracepoint_SOURCES = same_line_tracepoint.c ust_tests_sameline.h
+same_line_tracepoint_LDADD = \
+       $(top_builddir)/src/lib/lttng-ust/liblttng-ust.la \
+       $(DL_LIBS)
+
+# Compile without API0 compat macros
+same_line_tracepoint_compatapi1_SOURCES = same_line_tracepoint.c ust_tests_sameline.h
+same_line_tracepoint_compatapi1_CFLAGS = -DLTTNG_UST_COMPAT_API_VERSION=1 $(AM_CFLAGS)
+same_line_tracepoint_compatapi1_LDADD = \
+       $(top_builddir)/src/lib/lttng-ust/liblttng-ust.la \
+       $(DL_LIBS)
+
+EXTRA_DIST = README
This page took 0.023813 seconds and 4 git commands to generate.