Add api0 compile tests
[lttng-ust.git] / tests / compile / api0 / hello / Makefile.am
diff --git a/tests/compile/api0/hello/Makefile.am b/tests/compile/api0/hello/Makefile.am
new file mode 100644 (file)
index 0000000..75ab9e1
--- /dev/null
@@ -0,0 +1,8 @@
+# SPDX-License-Identifier: LGPL-2.1-only
+
+AM_CPPFLAGS += -I$(srcdir)
+
+noinst_PROGRAMS = hello
+hello_SOURCES = hello.c tp.c ust_tests_hello.h
+hello_LDADD = $(top_builddir)/src/lib/lttng-ust/liblttng-ust.la $(DL_LIBS)
+hello_CFLAGS = -Werror=old-style-definition $(AM_CFLAGS)
This page took 0.023352 seconds and 4 git commands to generate.