fix: python agent: Add a dependency on generated files
[lttng-ust.git] / python-lttngust / Makefile.am
index 6c0d20d5150b1104976a3d17488d859fb9aec719..b5154c0a68c0c0e3137963e72d80bc26b7f6be4a 100644 (file)
@@ -1,7 +1,11 @@
+GENERATED_BINDINGS_DEPS = \
+       lttngust/__init__.py \
+       setup.py
+
 # Use setup.py for the installation instead of Autoconf.
 # This ease the installation process and assure a *pythonic*
 # installation.
-all-local:
+all-local: $(GENERATED_BINDINGS_DEPS)
        $(PYTHON) setup.py build --verbose
 
 install-exec-local:
This page took 0.023229 seconds and 4 git commands to generate.