Disable sync/ completely, build OK
[lttv.git] / lttv / lttv / Makefile.am
index 170f4d5bd3d48d35c52538da70cf0435bb7bd1f9..fbf6d6aad21d789f6588be9747787384d4288fe9 100644 (file)
@@ -1,13 +1,23 @@
-AM_CFLAGS = $(GLIB_CFLAGS) 
-LIBS += $(THREAD_LIBS)
-LIBS += $(POPT_LIBS) $(GLIB_LIBS) -lgobject-2.0 -L${top_builddir}/ltt\
-          -llttvtraceread
+SUBDIRS= sync
+
+AM_CFLAGS= $(PACKAGE_CFLAGS)
+LDADD = $(POPT_LIBS) $(M_LIBS) $(GLPK_LIBS) ${top_builddir}/ltt/liblttvtraceread.la
 
 bin_PROGRAMS = lttv.real
 
+if BUILD_LTTV_GUI
 bin_SCRIPTS = lttv lttv-gui
+else
+bin_SCRIPTS = lttv
+endif
+
 CLEANFILES = $(bin_SCRIPTS)
+
+if BUILD_LTTV_GUI
 EXTRA_DIST = lttv.sh lttv-gui.sh
+else
+EXTRA_DIST = lttv.sh
+endif
 
 lttv: lttv.sh
        rm -f lttv
@@ -24,11 +34,43 @@ lttv-gui: lttv-gui.sh
 
 INCLUDES = \
        -DPACKAGE_PLUGIN_DIR=\""$(lttvplugindir)"\" \
-       @PACKAGE_CFLAGS@ \
        $(DEFAULT_INCLUDES)
 
 libdir = ${lttvplugindir}
 
+#noinst_HEADERS = \
+#      filter.h
+
+lttv_real_SOURCES = \
+       batchtest.c\
+       main.c\
+       module.c\
+       option.c\
+       hook.c\
+       attribute.c\
+       iattribute.c\
+       state.c\
+       stats.c\
+       tracecontext.c\
+       traceset.c\
+       filter.c\
+       print.c
+
+#Disabled by Mathieu Desnoyers (does not build on x86_64)
+#      sync/sync_chain.c\
+#      sync/sync_chain_lttv.c\
+#      sync/graph_functions.c\
+#      sync/data_structures.c\
+#      sync/event_processing_lttng_common.c\
+#      sync/event_processing_lttng_standard.c\
+#      sync/event_processing_lttng_null.c\
+#      sync/event_matching_broadcast.c\
+#      sync/event_matching_distributor.c\
+#      sync/event_matching_tcp.c\
+#      sync/event_analysis_chull.c\
+#      sync/event_analysis_eval.c\
+#      sync/event_analysis_linreg.c
+
 lttvinclude_HEADERS = \
        attribute.h\
        hook.h\
@@ -43,14 +85,6 @@ lttvinclude_HEADERS = \
        filter.h\
        print.h
 
-#noinst_HEADERS = \
-#      filter.h
-
-lttv_real_SOURCES = batchtest.c main.c module.c option.c \
-               hook.c attribute.c \
-               iattribute.c state.c stats.c \
-              tracecontext.c traceset.c filter.c print.c
-
 #man_MANS = lttv.1
 #EXTRA_DIST = lttv.1
 
@@ -62,6 +96,6 @@ lttv_real_SOURCES = batchtest.c main.c module.c option.c \
 lttv_real_LDFLAGS = -export-dynamic
 
 if LTTVSTATIC
-  lttv_real_LDFLAGS += -profile -static
+  lttv_real_LDFLAGS += -static
 endif
 
This page took 0.025678 seconds and 4 git commands to generate.