Add a unittest program for clock synchronization modules
[lttv.git] / lttv / lttv / Makefile.am
index b0bc52f4c1d0ed2ccd78ad4e289fbf82b520f2b5..58fd59586badbaeda401fa484faef95e0d240d0f 100644 (file)
@@ -1,11 +1,23 @@
+SUBDIRS= sync
+
 AM_CFLAGS= $(PACKAGE_CFLAGS)
-LDADD = $(POPT_LIBS) ${top_builddir}/ltt/liblttvtraceread.la
+LDADD = $(POPT_LIBS) $(M_LIBS) ${top_builddir}/ltt/liblttvtraceread.la
 
 bin_PROGRAMS = lttv.real
 
+if BUILD_LTTV_GUI
 bin_SCRIPTS = lttv lttv-gui
+else
+bin_SCRIPTS = lttv
+endif
+
 CLEANFILES = $(bin_SCRIPTS)
+
+if BUILD_LTTV_GUI
 EXTRA_DIST = lttv.sh lttv-gui.sh
+else
+EXTRA_DIST = lttv.sh
+endif
 
 lttv: lttv.sh
        rm -f lttv
@@ -29,10 +41,42 @@ libdir = ${lttvplugindir}
 #noinst_HEADERS = \
 #      filter.h
 
-lttv_real_SOURCES = batchtest.c main.c module.c option.c \
-               hook.c attribute.c \
-               iattribute.c state.c stats.c \
-              tracecontext.c traceset.c filter.c print.c
+lttv_real_SOURCES = \
+       batchtest.c\
+       main.c\
+       module.c\
+       option.c\
+       hook.c\
+       attribute.c\
+       iattribute.c\
+       state.c\
+       stats.c\
+       tracecontext.c\
+       traceset.c\
+       filter.c\
+       print.c\
+       sync/sync_chain.c\
+       sync/data_structures_tcp.c\
+       sync/event_processing_lttv_common.c\
+       sync/event_processing_lttv_standard.c\
+       sync/event_processing_lttv_null.c\
+       sync/event_matching_tcp.c\
+       sync/event_analysis_linreg.c\
+       sync/event_analysis_chull.c
+
+lttvinclude_HEADERS = \
+       attribute.h\
+       hook.h\
+       iattribute.h\
+       lttv.h\
+       module.h\
+       option.h\
+       state.h\
+       stats.h\
+       tracecontext.h\
+       traceset.h\
+       filter.h\
+       print.h
 
 #man_MANS = lttv.1
 #EXTRA_DIST = lttv.1
This page took 0.022404 seconds and 4 git commands to generate.