Cleanup: test Makefiles
[lttng-ust.git] / tests / ust-elf / Makefile.am
index 203272ed155d7a057ebdd7ab832aaea06ab08f45..f115eea4629af7ac18999aa85041e6aaebd31bc7 100644 (file)
@@ -1,13 +1,11 @@
 AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/tests/utils
 
-noinst_PROGRAMS = prog
-prog_SOURCES = prog.c
-prog_LDADD = $(top_builddir)/liblttng-ust/liblttng-ust.la \
+noinst_PROGRAMS = ust-elf
+ust_elf_SOURCES = ust-elf.c
+ust_elf_LDADD = $(top_builddir)/liblttng-ust/liblttng-ust.la \
        $(top_builddir)/tests/utils/libtap.a
 
-noinst_SCRIPTS = test_ust_elf
-CLEANFILES = $(noinst_SCRIPTS)
-EXTRA_DIST = test_ust_elf.in \
+EXTRA_DIST = \
        $(srcdir)/data/main.c \
        $(srcdir)/data/aarch64_be/main.elf \
        $(srcdir)/data/aarch64_be/main.elf.debug \
@@ -22,7 +20,3 @@ EXTRA_DIST = test_ust_elf.in \
        $(srcdir)/data/pic/hello.pic \
        $(srcdir)/data/pic/hello.c \
        $(srcdir)/data/pic/libhello.c
-
-$(noinst_SCRIPTS): %: %.in
-       $(SED) "s#@ABSTOPSRCDIR@#$(abs_top_srcdir)#g" < $< > $@
-       chmod +x $@
This page took 0.024777 seconds and 4 git commands to generate.