Add more unit tests for possible_cpus_array_len
[lttng-ust.git] / tests / unit / libcommon / Makefile.am
index 05b894e89eb9b423504791bede270af124124fc2..77f3b852ae89954db71c0f22dd6a4e65390630a9 100644 (file)
@@ -2,8 +2,30 @@
 
 AM_CPPFLAGS += -I$(top_srcdir)/tests/utils
 
-noinst_PROGRAMS = test_smp
-test_smp_SOURCES = test_smp.c
-test_smp_LDADD = \
+noinst_PROGRAMS = \
+       get_cpu_mask_from_sysfs \
+       get_max_cpuid_from_sysfs \
+       test_get_max_cpuid_from_mask \
+       test_get_possible_cpus_array_len
+
+dist_noinst_SCRIPTS = \
+       test_get_cpu_mask_from_sysfs \
+       test_get_max_cpuid_from_sysfs
+
+get_cpu_mask_from_sysfs_SOURCES = get_cpu_mask_from_sysfs.c
+get_cpu_mask_from_sysfs_LDADD = \
+       $(top_builddir)/src/common/libcommon.la
+
+get_max_cpuid_from_sysfs_SOURCES = get_max_cpuid_from_sysfs.c
+get_max_cpuid_from_sysfs_LDADD = \
+       $(top_builddir)/src/common/libcommon.la
+
+test_get_max_cpuid_from_mask_SOURCES = test_get_max_cpuid_from_mask.c
+test_get_max_cpuid_from_mask_LDADD = \
+       $(top_builddir)/src/common/libcommon.la \
+       $(top_builddir)/tests/utils/libtap.a
+
+test_get_possible_cpus_array_len_SOURCES = test_get_possible_cpus_array_len.c
+test_get_possible_cpus_array_len_LDADD = \
        $(top_builddir)/src/common/libcommon.la \
        $(top_builddir)/tests/utils/libtap.a
This page took 0.02294 seconds and 4 git commands to generate.